hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Catalin Ionescu" <c...@elinuspro.com>
Subject VeriSign Global Server Intermediate Root CA
Date Tue, 20 Jan 2004 21:06:55 GMT
Jan. 09-2003 
I use a httpclient to download a file on a daily basis from https website 
The site has: 
VeriSign International Server CA - Class 3 

It was working all 2003 and I have installed httpclient version as Feb. 25th 2003 that was
available, but yesterday suddenly it failed with: 
<untrusted server cert chain> 

Using IE browser works. In my custom java program I use these sentences that allowed trust
before yesterday: 
Security.addProvider(new com.sun.net.ssl.internal.ssl.Provider()); 
System.setProperty("java.protocol.handler.pkgs","com.sun.net.ssl.internal.www.protocol");


Please read this news from VeriSign: 
https://www.verisign.com/support/vendors/exp-gsid-mpki.html 

Am I affected by the VeriSign Global Server ID Intermediate Root CA which expired on 1/7/2004;
does it help if I update httpclient on my side OR 
to make them aware to update the intermediate root CA certificate store on their server(s)
with the latest version of the VeriSign Global Server Intermediate Root CA and in this case
why is IE running fine? 


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-httpclient-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-httpclient-dev-help@jakarta.apache.org


Mime
View raw message