hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adrian Sutton <adr...@intencha.com>
Subject Re: Fw: unable to find line starting with "HTTP" error
Date Fri, 01 Aug 2003 13:25:14 GMT

On Friday, August 1, 2003, at 11:04  PM, linea@libero.it wrote:

> I tried sending a GET request but I catch always the same error
> "unable to find line starting with "HTTP".
>
> thanks again..

Hi,
The server is not responding with a valid HTTP response as it doesn't 
include a status line.  Even wget can't manage to connect:

[aj@Sexy perl]$ wget www.computerhistory.org
--23:18:41--  http://www.computerhistory.org/
            => `index.html'
Resolving www.computerhistory.org... done.
Connecting to www.computerhistory.org[64.60.242.254]:80... connected.
HTTP request sent, awaiting response...
23:18:42 ERROR -1: Malformed status line.

It is unreasonable to call this server a Http server let alone expect 
HttpClient to work with it.  You should report the problem to the 
system administrator of the server.

Also, from your latest log it still looks like some method is being 
executed before the GET method is and the trailing "</html>" is being 
left behind on the connection - Roland is very much right in pointing 
out the problems caused by a server returning data for a HEAD request 
and you may also be running into this problem.

Also of interest is:

[aj@Sexy perl]$ telnet www.computerhistory.org 80
Trying 64.60.242.254...
Connected to 64-60-242-254.cust.telepacific.net.
Escape character is '^]'.
GET /index.html\
Host: www.computerhistory.org


<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<HTML><HEAD>
<TITLE>404 Not Found</TITLE>
</HEAD><BODY>
<H1>Not Found</H1>
The requested URL /index.html\ was not found on this server.<P>
<HR>
<ADDRESS>Apache/1.3.20 Server at <A 
HREF="mailto:webmaster@computerhistory.org">computerhistory.org</A> 
Port 80</ADDRESS>
</BODY></HTML>
Connection closed by foreign host.

I wonder how they managed to configure Apache to not return a status 
line.

Anyway, past my bed time.

Regards,

Adrian Sutton.

----------------------------------------------
Intencha "tomorrow's technology today"
Ph: 38478913 0422236329
Suite 8/29 Oatland Crescent
Holland Park West 4121
Australia QLD
www.intencha.com


Mime
View raw message