hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 22421] - MultiPartPostMethod sends a different file than the one from file system
Date Thu, 14 Aug 2003 14:53:20 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=22421>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=22421

MultiPartPostMethod sends a different file than the one from file system





------- Additional Comments From adrian@ephox.com  2003-08-14 14:53 -------
Hi Alessio,
This sounds very suspiciously like the server is misinterpreting the multipart form content.
 There 
should be a blank line between the headers for the part and the start of the file (which HttpClient

will add so as to distinguish between the headers and the actual content).  This is part of
the 
specification and any correctly functioning server will start reading the actual data from
after the 
first blank line.  I would suggest testing the server with a standard web browser posting
a form to 
ensure the server is correct.

If you still think the problem is with HttpClient you'll need to provide a few things.  Most

importantly in this case will be a test case that shows the problem - the simpler the better.
 
Secondly we'll need to take a look at the wire log showing the problem, details are available
at 
http://jakarta.apache.org/commons/httpclient/logging.html there are some other useful tips
on 
troubleshooting at http://jakarta.apache.org/commons/httpclient/troubleshooting.html  We'll
also 
need to know as much as you can tell us about the server your running with including versions,
OS 
(and OS versions) etc.  The more information you can provide the easier it will be to track
down the 
problem.

Regards,

Adrian Sutton.

Mime
View raw message