hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oleg Kalnichevski <ol...@apache.org>
Subject Re: JDK 1.1.8 problems
Date Wed, 13 Aug 2003 20:46:45 GMT
David,
HttpClient requires Java 2 compatible JRE (> 1.2.x), primarily because
it uses Java 2 collections framework. We have never aimed at providing
Java 1.1 compatibility. 

Oleg


On Wed, 2003-08-13 at 22:47, David.Cowan@apcc.com wrote:
> I have upgraded from
> 
> commons-httpclient-2.0-alpha2  to commons-httpclient-2.0-rc1 and am now
> having problems in HttpConnection
> 
> 2003-08-13 17:10:26,233 ERROR: java.net.Socket: method getSendBufferSize()I
> not found
> 
> java.lang.NoSuchMethodError: java.net.Socket: method getSendBufferSize()I
> not found
>      at org.apache.commons.httpclient.HttpConnection.open()
>      at org.apache.commons.httpclient.HttpMethodBase.processRequest()
>      at org.apache.commons.httpclient.HttpMethodBase.execute()
> 
> 
> This method was added in 1.2 and is not supported in 1.1.8.
> 
> This was not a problem in alpha 2.  The offending lines of code is line
> 695, 748 and 1226 in HttpConnection.  Could this be conditionally used on
> < 1.2.
> 
> Ex:
> 
>             if (sendBufferSize != -1 &&
> Double.parseDouble(System.getProperty("java.version")) >=  1.2) {
>                 socket.setSendBufferSize(sendBufferSize);
>             }
> 
> 
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: commons-httpclient-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: commons-httpclient-dev-help@jakarta.apache.org
> 


Mime
View raw message