hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Moran <mike_mo...@mac.com>
Subject Re: 300 Multiple Choices handling?
Date Mon, 02 Jun 2003 12:22:05 GMT
Adrian Sutton wrote:
> 
> On Monday, June 2, 2003, at 09:57  PM, Mike Moran wrote:
> 
>> Adrian Sutton wrote:
[ ... ]
>> Umm. I think HttpClient and wget must disagree:
>>
>> $ wget --server-response 
>> http://www.blooberry.com//indexdotpreview/html/index8.htm
>> --12:48:55--  http://www.blooberry.com//indexdotpreview/html/index8.htm
>>            => `index8.htm'
>> Resolving www.blooberry.com... done.
>> Connecting to www.blooberry.com[204.122.16.82]:80... connected.
>> HTTP request sent, awaiting response...
>>  1 HTTP/1.1 300 Multiple Choices
>>
>> ...
>>
>> A telnet to port 80 for that page also gives 300 Multiple Choices.
> 
> 
> Interesting....  I do get a 300 from telnet, but a 302 from HttpClient:
> 302
> <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
> <HTML><HEAD>
> <TITLE>302 Found</TITLE>
> </HEAD><BODY>
> <H1>Found</H1>
> The document has moved <A 
> HREF="http://www.eskimo.com/notfound.html">here</A>.<P>
> </BODY></HTML>
[ ... ]

I wonder... is HttpClient perhaps parsing out "www.blooberry.com/" as 
the value for the Host: header? My URL is slightly bogus, though perhaps 
technically valid. What happens with:
http://www.blooberry.com/indexdotpreview/html/index8.htm
(Note no double slash)

www.eskimo.com and www.blooberry.com appear to be on the same subnet; 
www.eskimo.com is perhaps the default VirtualHost.

Just wondering ...

-- 
Mike Moran


Mime
View raw message