hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Brown" <bro...@reflexe.fr>
Subject Unmentioned dependencies
Date Thu, 10 Apr 2003 15:34:23 GMT

I didn't see any mention on the HttpClient website or in any other docs
about dependencies in HttpClient upon JCE (Java Cryptography Extensions) for
using NTLM.

I discovered (via a NoClassDefFound error) that the following classes are
required if you use NTCredentials :

javax.crypto.BadPaddingException;
javax.crypto.Cipher;
javax.crypto.IllegalBlockSizeException;
javax.crypto.NoSuchPaddingException;
javax.crypto.spec.SecretKeySpec;

Could you mention in the docs / on the site that JCE or JDK 1.4 (including
JCE) is required for NTLM authentification (so that others don't get stuck)?

Thanks,
Chris



Mime
View raw message