hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 15654] - HttpMethodBase does not handle response headers with missing ':'
Date Mon, 03 Feb 2003 15:02:27 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=15654>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=15654

HttpMethodBase does not handle response headers with missing ':'

jsdever@apache.org changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |RESOLVED
         Resolution|                            |INVALID
   Target Milestone|2.0 Beta 1                  |---



------- Additional Comments From jsdever@apache.org  2003-02-03 15:02 -------
I honestly can't accept that any server that does not seperate header names from
header values with a ':' is worth anything at all.  If the server does this, the
manufacturer should be notified and the problem corrected by the broken server.
 HttpClient will not be modified to accomodate.

I tested the url in question, http://www.porsche.com, and found that the
response headers are well formed.  There is a redirect to a web hosting service,
Netidentity, running IIS which works perfectly using HttpClient.

Marking this bug as INVALID

Mime
View raw message