hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oleg Kalnichevski <o.kalnichev...@dplanet.ch>
Subject Re: [PATCH] 'expect: 100-continue' handshake revisited
Date Thu, 27 Feb 2003 09:16:33 GMT
Ingo, 
The patch was not supposed to solve the bug, as I still have no clear
idea what may be causing the problem in the first place. It is merely a
refactoring and code improvement patch, that should make
'expect-continue' stuff more robust.

It appears the problem is somehow related to the use of SSL, but I can't
tell more at the moment

Cheers

Oleg

On Thu, 2003-02-27 at 09:56, Ingo Brunberg wrote:
> Hi Oleg,
> 
> I have tried your patch. Unfortunately it does not solve the
> problem. Sorry, that I cannot give you more help, but I also have no
> idea what might be causing that problem.
> 
> Regards,
> Ingo
> 
> > I have been trying to resolve the bug related to 'expect - continue'
> > handshake. We have been making some progress but I still have no clear
> > idea what may be causing this problem.  
> > 
> > However, while working on this bug I have come to believe that 'expect:
> > 100-continue' stuff in HttpClient is flaky and is in need of
> > improvement. The 'expect: 100-continue' related code is spread around a
> > few classes, is difficult to understand and to debug, and most
> > importantly error prone.   
> > 
> > Here is my attempt at fixing the situation.
> > 
> > You feedback will be appreciated, as always, even if you end up tearing
> > it apart, again. ;-)
> > 
> > Cheers
> > 
> > Oleg
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: commons-httpclient-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: commons-httpclient-dev-help@jakarta.apache.org
> 


Mime
View raw message