hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Bowler <mbow...@GargoyleSoftware.com>
Subject Dependancy on Java 1.4
Date Fri, 03 Jan 2003 11:11:04 GMT
I tried the code from CVS yesterday on a machine running Java 1.3.1 and 
discovered that there is now a hard dependancy on 1.4.  The Protocol 
class is using classes from the javax.net package which is new for 1.4.

This has happened a couple of times and nobody seems to realize that the 
runtime dependancy is there until there is a complaint.  Is it possible 
to get gump to run some of the tests on a 1.3 jvm to catch these 
problems earlier?

-- 
Mike Bowler
Principal, Gargoyle Software Inc.
Voice: (416) 822-0973 | Email  : mbowler@GargoyleSoftware.com
Fax  : (416) 822-0975 | Website: http://www.GargoyleSoftware.com



Mime
View raw message