hc-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Jenkins Server <jenk...@builds.apache.org>
Subject Build failed in Jenkins: httpcomponents-client-4.5.x » Apache HttpClient OSGi bundle #37
Date Thu, 20 Aug 2015 00:14:15 GMT
See <https://builds.apache.org/job/httpcomponents-client-4.5.x/org.apache.httpcomponents$httpclient-osgi/37/>

------------------------------------------
[INFO]                                                                         
[INFO] ------------------------------------------------------------------------
[INFO] Building Apache HttpClient OSGi bundle 4.5.1-SNAPSHOT
[INFO] ------------------------------------------------------------------------
[INFO] 
[INFO] --- maven-clean-plugin:2.5:clean (default-clean) @ httpclient-osgi ---
[INFO] Deleting <https://builds.apache.org/job/httpcomponents-client-4.5.x/org.apache.httpcomponents$httpclient-osgi/ws/target>
[INFO] 
[INFO] --- maven-checkstyle-plugin:2.9.1:checkstyle (validate) @ httpclient-osgi ---
[INFO] Starting audit...
Audit done.

[INFO] 
[INFO] --- maven-checkstyle-plugin:2.9.1:checkstyle (validate-main) @ httpclient-osgi ---
[INFO] Starting audit...
Audit done.

[INFO] 
[INFO] --- maven-checkstyle-plugin:2.9.1:checkstyle (validate-test) @ httpclient-osgi ---
[INFO] Starting audit...
Audit done.

[INFO] 
[INFO] --- maven-checkstyle-plugin:2.9.1:checkstyle (validate-examples) @ httpclient-osgi
---
[INFO] 
[INFO] --- maven-remote-resources-plugin:1.4:process (default) @ httpclient-osgi ---
[INFO] 
[INFO] --- buildnumber-maven-plugin:1.2:create (default) @ httpclient-osgi ---
[INFO] Checking for local modifications: skipped.
[INFO] Updating project files from SCM: skipped.
[INFO] Executing: /bin/sh -c cd <https://builds.apache.org/job/httpcomponents-client-4.5.x/org.apache.httpcomponents$httpclient-osgi/ws/>
&& svn --non-interactive info
[INFO] Working directory: <https://builds.apache.org/job/httpcomponents-client-4.5.x/org.apache.httpcomponents$httpclient-osgi/ws/>
[INFO] Storing buildNumber: 1696143 at timestamp: 1440029493688
[INFO] Executing: /bin/sh -c cd <https://builds.apache.org/job/httpcomponents-client-4.5.x/org.apache.httpcomponents$httpclient-osgi/ws/>
&& svn --non-interactive info
[INFO] Working directory: <https://builds.apache.org/job/httpcomponents-client-4.5.x/org.apache.httpcomponents$httpclient-osgi/ws/>
[INFO] Storing buildScmBranch: branches/4.5.x/httpclient-osgi
[INFO] 
[INFO] --- maven-resources-plugin:2.6:resources (default-resources) @ httpclient-osgi ---
[INFO] Using 'UTF-8' encoding to copy filtered resources.
[INFO] Copying 2 resources
[INFO] Copying 3 resources
[INFO] 
[INFO] --- maven-compiler-plugin:3.1:compile (default-compile) @ httpclient-osgi ---
[INFO] Changes detected - recompiling the module!
[INFO] Compiling 12 source files to <https://builds.apache.org/job/httpcomponents-client-4.5.x/org.apache.httpcomponents$httpclient-osgi/ws/target/classes>
[WARNING] Note: Some input files use unchecked or unsafe operations.
[WARNING] Note: Recompile with -Xlint:unchecked for details.
[INFO] 
[INFO] --- maven-dependency-plugin:2.1:copy-dependencies (copy-bundles) @ httpclient-osgi
---
[INFO] Copying commons-codec-1.9.jar to <https://builds.apache.org/job/httpcomponents-client-4.5.x/org.apache.httpcomponents$httpclient-osgi/ws/target/bundles/commons-codec-1.9.jar>
[INFO] Copying commons-logging-1.2.jar to <https://builds.apache.org/job/httpcomponents-client-4.5.x/org.apache.httpcomponents$httpclient-osgi/ws/target/bundles/commons-logging-1.2.jar>
[INFO] Copying httpcore-osgi-4.4.1.jar to <https://builds.apache.org/job/httpcomponents-client-4.5.x/org.apache.httpcomponents$httpclient-osgi/ws/target/bundles/httpcore-osgi-4.4.1.jar>
[INFO] Copying org.osgi.compendium-5.0.0.jar to <https://builds.apache.org/job/httpcomponents-client-4.5.x/org.apache.httpcomponents$httpclient-osgi/ws/target/bundles/org.osgi.compendium-5.0.0.jar>
[INFO] 
[INFO] --- maven-resources-plugin:2.6:testResources (default-testResources) @ httpclient-osgi
---
[INFO] Using 'UTF-8' encoding to copy filtered resources.
[INFO] Copying 1 resource
[INFO] Copying 3 resources
[INFO] 
[INFO] --- maven-compiler-plugin:3.1:testCompile (default-testCompile) @ httpclient-osgi ---
[INFO] Changes detected - recompiling the module!
[INFO] Compiling 2 source files to <https://builds.apache.org/job/httpcomponents-client-4.5.x/org.apache.httpcomponents$httpclient-osgi/ws/target/test-classes>
[WARNING] <https://builds.apache.org/job/httpcomponents-client-4.5.x/org.apache.httpcomponents$httpclient-osgi/ws/src/test/java/org/apache/http/osgi/impl/MimeExportedIT.java>:
warning: org/ops4j/pax/exam/Configuration.class(org/ops4j/pax/exam:Configuration.class): major
version 51 is newer than 50, the highest major version supported by this compiler.
It is recommended that the compiler be upgraded.
[WARNING] <https://builds.apache.org/job/httpcomponents-client-4.5.x/org.apache.httpcomponents$httpclient-osgi/ws/src/test/java/org/apache/http/osgi/impl/MimeExportedIT.java>:
warning: org/ops4j/pax/exam/Option.class(org/ops4j/pax/exam:Option.class): major version 51
is newer than 50, the highest major version supported by this compiler.
It is recommended that the compiler be upgraded.
[WARNING] <https://builds.apache.org/job/httpcomponents-client-4.5.x/org.apache.httpcomponents$httpclient-osgi/ws/src/test/java/org/apache/http/osgi/impl/MimeExportedIT.java>:
warning: org/ops4j/pax/exam/junit/PaxExam.class(org/ops4j/pax/exam/junit:PaxExam.class): major
version 51 is newer than 50, the highest major version supported by this compiler.
It is recommended that the compiler be upgraded.
[WARNING] <https://builds.apache.org/job/httpcomponents-client-4.5.x/org.apache.httpcomponents$httpclient-osgi/ws/src/test/java/org/apache/http/osgi/impl/MimeExportedIT.java>:
warning: org/ops4j/pax/exam/spi/reactors/ExamReactorStrategy.class(org/ops4j/pax/exam/spi/reactors:ExamReactorStrategy.class):
major version 51 is newer than 50, the highest major version supported by this compiler.
It is recommended that the compiler be upgraded.
[WARNING] <https://builds.apache.org/job/httpcomponents-client-4.5.x/org.apache.httpcomponents$httpclient-osgi/ws/src/test/java/org/apache/http/osgi/impl/MimeExportedIT.java>:
warning: org/ops4j/pax/exam/spi/reactors/PerClass.class(org/ops4j/pax/exam/spi/reactors:PerClass.class):
major version 51 is newer than 50, the highest major version supported by this compiler.
It is recommended that the compiler be upgraded.
[WARNING] <https://builds.apache.org/job/httpcomponents-client-4.5.x/org.apache.httpcomponents$httpclient-osgi/ws/src/test/java/org/apache/http/osgi/impl/MimeExportedIT.java>:
warning: org/ops4j/pax/exam/CoreOptions.class(org/ops4j/pax/exam:CoreOptions.class): major
version 51 is newer than 50, the highest major version supported by this compiler.
It is recommended that the compiler be upgraded.
[WARNING] <https://builds.apache.org/job/httpcomponents-client-4.5.x/org.apache.httpcomponents$httpclient-osgi/ws/src/test/java/org/apache/http/osgi/impl/MimeExportedIT.java>:
warning: org/ops4j/pax/exam/spi/reactors/EagerSingleStagedReactorFactory.class(org/ops4j/pax/exam/spi/reactors:EagerSingleStagedReactorFactory.class):
major version 51 is newer than 50, the highest major version supported by this compiler.
It is recommended that the compiler be upgraded.
[WARNING] <https://builds.apache.org/job/httpcomponents-client-4.5.x/org.apache.httpcomponents$httpclient-osgi/ws/src/test/java/org/apache/http/osgi/impl/MimeExportedIT.java>:
warning: org/ops4j/pax/exam/spi/StagedExamReactorFactory.class(org/ops4j/pax/exam/spi:StagedExamReactorFactory.class):
major version 51 is newer than 50, the highest major version supported by this compiler.
It is recommended that the compiler be upgraded.
[WARNING] <https://builds.apache.org/job/httpcomponents-client-4.5.x/org.apache.httpcomponents$httpclient-osgi/ws/src/test/java/org/apache/http/osgi/impl/MimeExportedIT.java>:
warning: org/ops4j/pax/exam/options/ProvisionOption.class(org/ops4j/pax/exam/options:ProvisionOption.class):
major version 51 is newer than 50, the highest major version supported by this compiler.
It is recommended that the compiler be upgraded.
[WARNING] <https://builds.apache.org/job/httpcomponents-client-4.5.x/org.apache.httpcomponents$httpclient-osgi/ws/src/test/java/org/apache/http/osgi/impl/MimeExportedIT.java>:
warning: org/ops4j/pax/exam/options/CompositeOption.class(org/ops4j/pax/exam/options:CompositeOption.class):
major version 51 is newer than 50, the highest major version supported by this compiler.
It is recommended that the compiler be upgraded.
[WARNING] <https://builds.apache.org/job/httpcomponents-client-4.5.x/org.apache.httpcomponents$httpclient-osgi/ws/src/test/java/org/apache/http/osgi/impl/MimeExportedIT.java>:
warning: org/ops4j/pax/exam/options/SystemPropertyOption.class(org/ops4j/pax/exam/options:SystemPropertyOption.class):
major version 51 is newer than 50, the highest major version supported by this compiler.
It is recommended that the compiler be upgraded.
[WARNING] <https://builds.apache.org/job/httpcomponents-client-4.5.x/org.apache.httpcomponents$httpclient-osgi/ws/src/test/java/org/apache/http/osgi/impl/MimeExportedIT.java>:
warning: org/ops4j/pax/exam/options/ValueOption.class(org/ops4j/pax/exam/options:ValueOption.class):
major version 51 is newer than 50, the highest major version supported by this compiler.
It is recommended that the compiler be upgraded.
[INFO] 
[INFO] --- maven-surefire-plugin:2.15:test (default-test) @ httpclient-osgi ---
[INFO] Surefire report directory: <https://builds.apache.org/job/httpcomponents-client-4.5.x/org.apache.httpcomponents$httpclient-osgi/ws/target/surefire-reports>

-------------------------------------------------------
 T E S T S
-------------------------------------------------------
Running org.apache.http.osgi.impl.TestPropertiesUtils
Tests run: 6, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 0.051 sec - in org.apache.http.osgi.impl.TestPropertiesUtils

Results :

Tests run: 6, Failures: 0, Errors: 0, Skipped: 0

[JENKINS] Recording test results
[INFO] 
[INFO] --- maven-bundle-plugin:2.4.0:bundle (default-bundle) @ httpclient-osgi ---
[INFO] 
[INFO] --- maven-site-plugin:3.3:attach-descriptor (attach-descriptor) @ httpclient-osgi ---
[INFO] 
[INFO] --- maven-checkstyle-plugin:2.9.1:checkstyle (validate) @ httpclient-osgi ---
[INFO] Starting audit...
Audit done.

[INFO] 
[INFO] --- maven-checkstyle-plugin:2.9.1:checkstyle (validate-main) @ httpclient-osgi ---
[INFO] Starting audit...
Audit done.

[INFO] 
[INFO] --- maven-checkstyle-plugin:2.9.1:checkstyle (validate-test) @ httpclient-osgi ---
[INFO] Starting audit...
Audit done.

[INFO] 
[INFO] --- maven-checkstyle-plugin:2.9.1:checkstyle (validate-examples) @ httpclient-osgi
---
[WARNING] Failed to getClass for org.apache.maven.plugin.source.SourceJarMojo
[INFO] 
[INFO] --- maven-source-plugin:2.2.1:jar (attach-sources) @ httpclient-osgi ---
[INFO] Building jar: <https://builds.apache.org/job/httpcomponents-client-4.5.x/org.apache.httpcomponents$httpclient-osgi/ws/target/org.apache.httpcomponents.httpclient_4.5.1-SNAPSHOT-sources.jar>
[INFO] 
[INFO] --- maven-javadoc-plugin:2.9.1:jar (attach-javadocs) @ httpclient-osgi ---
[INFO] Fixed Javadoc frame injection vulnerability (CVE-2013-1571) in 1 files.
[INFO] Building jar: <https://builds.apache.org/job/httpcomponents-client-4.5.x/org.apache.httpcomponents$httpclient-osgi/ws/target/org.apache.httpcomponents.httpclient_4.5.1-SNAPSHOT-javadoc.jar>
[INFO] 
[INFO] --- maven-failsafe-plugin:2.18.1:integration-test (default) @ httpclient-osgi ---
[INFO] Failsafe report directory: <https://builds.apache.org/job/httpcomponents-client-4.5.x/org.apache.httpcomponents$httpclient-osgi/ws/target/failsafe-reports>

-------------------------------------------------------
 T E S T S
-------------------------------------------------------

Results :

Tests run: 0, Failures: 0, Errors: 0, Skipped: 0

[JENKINS] Recording test results

Mime
View raw message