hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rebekah K." <dodovski...@gmail.com>
Subject Reporting Error: FSHLog
Date Wed, 12 Jun 2019 14:35:31 GMT
Hello,

I was recently trying to install and run hbase with my hadoop installation
and was wanting to report the following error I ran into and how I was able
to solve it...

Hadoop Version: Hadoop 3.1.2
Hbase Version: 2.1.5

I was able to get Hbase up and running and bring up the Hbase shell. I was
able to successfully run a 'list' command right off the bat but when I
tried to run a 'create' command I would get the following error....

[image: image.png]
I would also get the following error in my regionserver logs...
[image: image.png]
I found from your guy's git hub (
https://github.com/apache/hbase/blob/master/src/main/asciidoc/_chapters/troubleshooting.adoc#trouble.rs.startup)
a related error with FSHLog to add the following to the hbase config file...

<property>
  <name>hbase.wal.provider</name>
  <value>filesystem</value>
</property>

After adding that, and resetting hbase the error not longer occurred.

Thank you guys for your help, just wanted to report this in case it is
useful :)

Best,

Rebekah Kambara

Mime
  • Unnamed multipart/related (inline, None, 0 bytes)
View raw message