hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From George Forman <georgeforma...@hotmail.com>
Subject Re: hbase.regionserver.impl no longer available
Date Thu, 29 Dec 2016 16:24:04 GMT
Hi Ted,

I need to consult management on whether I am able to publish the code.

I might be able to publish a snippet of the code so I can get assistance.

thx

________________________________
From: Ted Yu <yuzhihong@gmail.com>
Sent: Thursday, December 29, 2016 4:10 PM
To: user@hbase.apache.org
Subject: Re: hbase.regionserver.impl no longer available

Can you show your code involving usage of hbase.regionserver.impl ?

Please also show the full stack trace of NPE.

A quick check across 0.98, branch-1 and master doesn't reveal difference
around this config.

Cheers

On Thu, Dec 29, 2016 at 7:51 AM, George Forman <georgeforman69@hotmail.com>
wrote:

> Hi,
>
> I have upgraded from cdh4.x to cdh5.6.0. We use HBase RegionServer
> coprocessor (observer model) for prepost for our data analysis. The
> coprocessor uses our proprietory statistics collection, as well as,
> implementing our JMX interface to retrieve those stats. To do this we have
> leveraged  hbase.regionserver.impl by providing our extension of
> HRegioinServer. eg: public class MyStatsHRegionServer extends HRegionServer
> {...}
>
>
>
> We are getting a NPE when the region server executes the coprocessor
> because I can't specify the extended class via hbase.regionserver.impl. I
> have looked around at hbase classes and can't find anything obvious that is
> a replacement. Does anyone have a suggestion on how to resolve this problem?
>
>
> Thanks
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message