hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sandeep vura <sandeepv...@gmail.com>
Subject Re: Unable to read namespace in HBASE.
Date Tue, 27 Dec 2016 09:20:53 GMT
Can you please help me to understand . I am using HBASE 1.2 version. and
bug (HBASE-14818) says affect version 1.2.0 and fieed in 2.0.0
<https://issues.apache.org/jira/browse/HBASE/fixforversion/12327188>, 1.3.0
<https://issues.apache.org/jira/browse/HBASE/fixforversion/12332794>, 1.4.0
<https://issues.apache.org/jira/browse/HBASE/fixforversion/12334929>, 1.2.2
<https://issues.apache.org/jira/browse/HBASE/fixforversion/12335440>,
0.98.20 <https://issues.apache.org/jira/browse/HBASE/fixforversion/12335472>
.

Is it a bug in Hbase 1.2.0?

Regards,
San

On Tue, Dec 27, 2016 at 2:48 PM, Ted Yu <yuzhihong@gmail.com> wrote:

> Looks like the release you're using doesn't have HBASE-14818.
>
> Can you find the release which has the fix for HBASE-14818 ?
>
> Thanks
>
> On Mon, Dec 26, 2016 at 9:53 PM, sandeep vura <sandeepvura@gmail.com>
> wrote:
>
>> Hi Ted,
>>
>> Thanks for looking into it,
>>
>> I am using  Version 1.2.0-cdh5.8.2
>>
>> Regards,
>> San
>>
>>
>>
>> On Tue, Dec 27, 2016 at 11:15 AM, Ted Yu <yuzhihong@gmail.com> wrote:
>>
>>> Which release are you using ?
>>>
>>> Have you taken a look at
>>> https://issues.apache.org/jira/browse/HBASE-14818
>>>
>>> > On Dec 26, 2016, at 9:33 PM, sandeep vura <sandeepvura@gmail.com>
>>> wrote:
>>> >
>>> > Hi Team,
>>> >
>>> > I have given "R" permission from hbase shell to namespace "d1" to user
>>> > (svura) and group (hadoopdev).
>>> >
>>> > when i logged in as user(svura) to hbase shell . I am unable to find
>>> > namespace (d1) since i had given "R" permission.
>>> >
>>> > Below Commands executed as hbase admin:
>>> >
>>> > 1. list_namespace from hbase user. (It will list all namespace)
>>> > 2. grant 'svura','R','@d1'  ( permission to user)
>>> > 3. grant '@hadoopdev','R','@d1' ( permission to group )
>>> > 3. Logged in as svura in other terminal listing namespace shows empty.
>>> >
>>> > Note: Even after grant 'RWXC' Also not listing namespace  user(svura).
>>> Only
>>> > if i give 'RWXCA' to namespace it working.
>>> >
>>> > Please let me know what i am missing here.
>>> >
>>> > Expected solution:
>>> >
>>> > user should only have read permission to namespace(d1) .Should show the
>>> > namespace to that user when only grant R permission,
>>> >
>>> > Regards,
>>> > San
>>>
>>
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message