hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "lk_hbase"<lk_hb...@163.com>
Subject Re: Re: too many connection to zookeeper from one regionserver
Date Fri, 16 Dec 2016 05:47:15 GMT
thanks for your reply Ted. I found what was wrong. It's one index I was build by phoenix which
just lost it's data on hdfs a few days ago , and hbase alway try to read it 

2016-12-16 

lk_hbase 



发件人:Ted Yu <yuzhihong@gmail.com>
发送时间:2016-12-16 11:05
主题:Re: too many connection to zookeeper from one regionserver
收件人:"user@hbase.apache.org"<user@hbase.apache.org>
抄送:

Was dev1 hosting hbase:meta table (before the stop) ? 

Looks like you embedded some image which didn't go through. 
Consider using third party site if text is not enough to convey the message. 

On Thu, Dec 15, 2016 at 7:02 PM, lk_hbase <lk_hbase@163.com> wrote: 

> hi,all: 
> I'm useing hbase 1.2.3 zookeeper 3.4.9 hadoop2.7.3 for test . there is 
> some table with few data. 
> and I use Phoenix4.9 for hbase1.2 as JDBC level . recently I got too many 
> connections error , and I rise zookeeper's maxClientCnxns=300. 
> but few days later I got the error again. 
> and I fond one regionserver always create new connection to zookeeper. so 
> I stop the regionserver. then I found another 
> region will do the samething again ,always make new connection  to 
> zookeeper. I don't know why ? 
> and from the web site I found something unusual: 
> 
> 
> only one region server memstore keep growing(dev1). If I stop dev1 , 
> another regionserver maybe dev5 will be the same.?? 
> 
> 2016-12-16 
> ------------------------------ 
> lk_hbase 
> 
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message