hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Yu <yuzhih...@gmail.com>
Subject problem in launching HBase
Date Tue, 15 Nov 2016 03:01:20 GMT
2016-11-10 11:25:14,177 INFO  [main-SendThread(localhost:2181)]
zookeeper.ClientCnxn: Opening socket connection to server localhost/
*127.0.0.1*:2181. Will not attempt to           authenticate using SASL
(unknown error)

Was the zookeeper quorum running on the localhost ?

In the future, use pastebin for passing config / log files - attachment
would be stripped by mailing list.

Have you read this ?

http://hbase.apache.org/book.html#quickstart_fully_distributed

On Mon, Nov 14, 2016 at 6:26 PM, QI Congyun <Congyun.Qi@alcatel-sbell.com.cn
> wrote:

>
> My previous e-mail is attached, pls check if the relative traces are
> enough to investigate or not?
> My node configuration are also enclosed.
>
> Thanks a lot.
>
>
> ---------- Forwarded message ----------
> From: QI Congyun <Congyun.Qi@alcatel-sbell.com.cn>
> To: "user-info@hbase.apache.org" <user-info@hbase.apache.org>
> Cc:
> Date: Mon, 14 Nov 2016 08:20:11 +0000
> Subject: my questions about launching HBase
>
> Hi, Specialist,
>
>
>
> I try to set up a HBase database, but the HBase is always raised some
> errors. I had ever sent the e-mail to one of hbase mail-list, the e-mail is
> refused some times, then I try to submit my questions to the new mail-box,
> hope to receive your response.
>
> Thanks a lot.
>
>
>
> my hadoop version is Hadoop-2.7.3,
>
> my OS is: CEOS linux6.4.
>
>
>
>
> ---------- Forwarded message ----------
> From: QI Congyun <Congyun.Qi@alcatel-sbell.com.cn>
> To: "hbase-dev@lists.apache.org" <hbase-dev@lists.apache.org>
> Cc:
> Date: Fri, 11 Nov 2016 02:01:58 +0000
> Subject: FW: my questions are always not resolved about hbase
>
>
>
> The E-mail can’t be sent to the destination e-mail box, resent it again.
>
>
>
> Thanks.
>
>
>
> *From:* QI Congyun
> *Sent:* Thursday, November 10, 2016 11:53 AM
> *To:* 'hbase-dev@lists.apache.org'
> *Subject:* my questions are always not resolved about hbase
>
>
>
> Hello sir,
>
>
>
> So sorry to bather you, I’m interested in the Hadoop system, and attempted
> to use Hadoop and Hbase, but the Hbase issue can’t be resolved, could you
> help me? Thanks in advance.
>
>
>
> 1.       I’m very bewildered why the same issue is always encountered
> when launching hbase each time, the raised information is attached as
> follows:
>
>
>
> *[hadoop@hadoop2 hbase-1.2.3]$ *
>
> *[hadoop@hadoop2 hbase-1.2.3]$ bin/start-hbase.sh *
>
> *localhost: starting zookeeper, logging to
> /home/hadoop/hbase-1.2.3/bin/../logs/hbase-hadoop-zookeeper-hadoop2.out*
>
> *localhost: java.io.IOException: Unable to create data dir
> /home/testuser/zookeeper*
>
> *localhost:      at
> org.apache.hadoop.hbase.zookeeper.HQuorumPeer.writeMyID(HQuorumPeer.java:157)*
>
> *localhost:      at
> org.apache.hadoop.hbase.zookeeper.HQuorumPeer.main(HQuorumPeer.java:70)*
>
> *starting master, logging to
> /home/hadoop/hbase-1.2.3/logs/hbase-hadoop-master-hadoop2.out*
>
> *starting regionserver, logging to
> /home/hadoop/hbase-1.2.3/logs/hbase-hadoop-1-regionserver-hadoop2.out*
>
> ……………
>
> *[hadoop@hadoop2 hbase-1.2.3]$ jps*
>
> *11805 SecondaryNameNode*
>
> *11614 DataNode*
>
> *507 NodeManager*
>
> *30687 HRegionServer*
>
> *385 ResourceManager*
>
> *11379 NameNode*
>
> *30899 Jps*
>
> *……………………..*
>
> *[hadoop@hadoop2 hbase-1.2.3]$ bin/stop-hbase.sh *
>
> *stopping hbasecat: /tmp/hbase-hadoop-master.pid: No such file or
> directory*
>
>
>
> *localhost: no zookeeper to stop because no pid file
> /tmp/hbase-hadoop-zookeeper.pid*
>
>
>
> 2.       When I check the logs, and a fatal errors are raised once again,
> but I don’t know why.
>
>
>
> 2016-11-10 11:25:14,177 INFO  [main-SendThread(localhost:2181)]
> zookeeper.ClientCnxn: Opening socket connection to server localhost/
> 127.0.0.1:2181. Will not attempt to authenticate using SASL (unknown
> error)
>
> 2016-11-10 11:25:14,181 WARN  [main-SendThread(localhost:2181)]
> zookeeper.ClientCnxn: Session 0x0 for server null, unexpected error,
> closing socket connection and attempting reconnect
>
> java.net.ConnectException: Connection refused
>
>               at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)
>
>               at sun.nio.ch.SocketChannelImpl.finishConnect(
> SocketChannelImpl.java:739)
>
>               at org.apache.zookeeper.ClientCnxnSocketNIO.doTransport(
> ClientCnxnSocketNIO.java:361)
>
>               at org.apache.zookeeper.ClientCnxn$SendThread.run(
> ClientCnxn.java:1081)
>
> 2016-11-10 11:25:14,291 INFO  [main-SendThread(localhost:2181)]
> zookeeper.ClientCnxn: Opening socket connection to server
> localhost/0:0:0:0:0:0:0:1:2181. Will not attempt to authenticate using
> SASL (unknown error)
>
> 2016-11-10 11:25:14,294 WARN  [main-SendThread(localhost:2181)]
> zookeeper.ClientCnxn: Session 0x0 for server null, unexpected error,
> closing socket connection and attempting reconnect
>
> java.net.ConnectException: Connection refused
>
>
>
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message