hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From kumar r <kumarc...@gmail.com>
Subject HBase rest service did not respond in a secure cluster
Date Tue, 11 Oct 2016 05:24:45 GMT
Hi,


HBase Version 1.1.5
OS - Windows

I have enabled HBase rest service with SSL and Proxy.

When accessing HBase rest url,

https://machine1:8082/ <https://machine1:8082/version/cluster>

it returns nothing and keep on loading.

<property>
  <name>hbase.rest.keytab.file</name>
  <value>thrift.keytab</value></property><property>
  <name>hbase.rest.kerberos.principal</name>
  <value>Principal</value></property><property>
  <name>hbase.rest.support.proxyuser</name>
  <value>true</value></property><property>
  <name>hbase.rest.authentication.type</name>
  <value>kerberos</value></property><property>
  <name>hbase.rest.authentication.kerberos.principal</name>
  <value>HTTP/_HOST@EXAMPLE.COM</value></property><property>
  <name>hbase.rest.authentication.kerberos.keytab</name>
  <value>http.keytab</value></property><property>
  <name>hbase.rest.ssl.enabled</name>
  <value>true</value></property><property>
  <name>hbase.rest.ssl.keystore.store</name>
  <value>keystore</value></property><property>
  <name>hbase.rest.ssl.keystore.password</name>
  <value>pass</value></property><property>
  <name>hbase.rest.ssl.keystore.keypassword</name>
  <value>keypass</value></property><property>
  <name>hbase.rest.port</name>
  <value>8082</value></property>

After sometimes, logs shows

Unavailable
org.apache.hadoop.hbase.client.RetriesExhaustedEception: Failed after
attempts=14, exceptions:
Mon Oct 10 12:55:21 IST 2016,
RpcRetryingCaller{globalStartTime=1476084308042, pause=1000,
retries=14}, org.apache.hadoop.hbase.MasterNotRunningException:
com.google.protobuf.ServiceException:
org.apache.hadoop.hbase.exceptions.ConnectionClosingException: Call to
machine2/192.168.60.4:60000 failed on local exception:
org.apache.hadoop.hbase.exceptions.ConnectionClosingException:
Connection to machine2/192.168.60.4:60000 is closing. Call id=66,
waitTime=13088

Do i miss anything?

Any help would be appreciated.

Stackoverflow:
http://stackoverflow.com/questions/39952755/hbase-rest-service-did-not-respond-in-a-secure-cluster


Thanks,

Kumar

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message