hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From kumar r <kumarc...@gmail.com>
Subject Re: HBase rest api not working for getting namespaces
Date Fri, 14 Oct 2016 06:58:23 GMT
Hi,

Namespaces support available from HBase-1.2.0. But i am using HBase-1.1.5
version.

https://issues.apache.org/jira/browse/HBASE-14147

Thanks,
Kumar

On Fri, Oct 14, 2016 at 12:26 PM, kumar r <kumarccpp@gmail.com> wrote:

> Hi,
>
> Namespaces support available from HBase-1.2.0. But i am using HBase-1.1.5
> version.
>
>
> On Wed, Oct 12, 2016 at 3:31 PM, kumar r <kumarccpp@gmail.com> wrote:
>
>> Hi,
>>
>> I have configured HBase rest service. Below API's are working properly
>>
>> /version/cluster
>> /status/cluster
>> /
>>
>> But get namespaces and creating new table is not working.
>>
>> 1. List namespace
>>
>> curl -vi -X GET \
>>   -H "Accept: application/json" \
>>   "http://example.com:8000/namespaces/"
>>
>> Exception: HTTP Error 405 - Method not allowed
>>
>> 2. Create or update table schema
>>
>> curl -vi -X POST \
>>   -H "Accept: application/json" \
>>   -H "Content-Type: application/json" \
>>   -d '{"TableSchema": {"name": "users","ColumnSchema": { "name": "cf" }}' \
>>   "http://example.com:8000/users/schema"
>>
>> Exception: Bad request - The remote server returned an error: (500) Internal Server
Error
>>
>> I am following the below documentation,
>>
>> http://hbase.apache.org/book.html#_using_rest_endpoints
>>
>> Why it is not working? Any other example available for HBase rest api?
>>
>>
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message