hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Heng Chen <heng.chen.1...@gmail.com>
Subject Re: Increased response time of hbase calls
Date Thu, 22 Sep 2016 06:56:42 GMT
Not sure hbase m7 is which version of hbase in community.

Is your batch load job some kind of bulk load or just call HTable API
to dump data to HBase?


2016-09-22 14:30 GMT+08:00 Dima Spivak <dimaspivak@apache.org>:
> Hey Deepak,
>
> Assuming I understand your question, I think you'd be better served
> reaching out to MapR directly. Our community isn't involved in M7 so the
> average user (or dev) wouldn't know about the ins and outs of that
> offering.
>
> On Wednesday, September 21, 2016, Deepak Khandelwal <
> dkhandelwal.tia@gmail.com> wrote:
>
>> Hi all
>>
>> I am facing an issue while accessing data from an hbase m7 table which has
>> about 50 million records.
>>
>> In a single Api request, we make 3 calls to hbase m7.
>> 1. Single Multi get to fetch about 30 records
>> 2. Single multi-put to update about 500 records
>> 3. Single multi-get to fetch about 15 records
>>
>> We consistently get the response in less than 200 seconds for approx
>> 99%calls. We have a tps of about 200 with 8vm's.
>> But we get issue everyday between 4pm and 6pm when Api response time gets
>> significant increase to from 200ms to 7-8sec. This happens because we have
>> a daily batch load That runs between 4and 6pm that puts multiple entries
>> into same hbase table.
>>
>> We are trying to find a solution to this problem that why response time
>> increases when batch load runs. We cannot change the time of batch job. Is
>> there anything we could do to resolve this issue?any help or pointers would
>> be much appreciated. Thanks
>>
>
>
> --
> -Dima

Mime
View raw message