hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted <r6squee...@gmail.com>
Subject hbase replication : ERROR: Connection refused
Date Tue, 23 Aug 2016 20:46:15 GMT
Hi I'm running hbase 1.2.1 and I'm getting an error trying to setup
replication.

I have 2 hbase systems running fine,
I can connect from both to each other via ssh and on all ports as there's
no firewall (this is just a test system).
I can connect from the source to the destination ZK on port 2181

When I try to enable replication though I get "ERROR: Connection refused"
with no other helpful information anywhere.

---
    hbase(main):002:0> create 'test', 'cf'
    0 row(s) in 2.5390 seconds

    => Hbase::Table - test
    hbase(main):003:0> add_peer 'vm2', "vm2:2181:/hbase"
    0 row(s) in 0.1830 seconds

    hbase(main):004:0> enable_table_replication 'test'

    ERROR: Connection refused

    Here is some help for this command:
    Enable a table's replication switch.

    Examples:

      hbase> enable_table_replication 'table_name'


    hbase(main):005:0>
---

There's no errors on the source logs, no log entries written at all during
the enable call.
On the destination logs there are also no errors.
If I do a "zk_dump" on the destination, I can see the source is actually
connected.

No replication is taking place, and other than that "error: connection
refused", I see no error messages.

Anyone with any ideas on what and where it's trying to connect to? and why
it's being refused?

-- 
Ted.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message