hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From kumar r <kumarc...@gmail.com>
Subject HBase acl commands are too slow
Date Mon, 13 Jun 2016 05:19:41 GMT
Hi,

I have configured secure HBase-1.1.3. Hadoop version using 2.7.2.

I have enabled authorization in HBase.

When executing any authorization command like user_permission, grant, revoke,
etc.

Its getting more than 40 seconds to display the result.

Below are hbase-site.xml configuration properties


<property>
    <name>hbase.master</name>
    <value>IP:60000</value>
</property>
<property>
    <name>hbase.rootdir</name>
    <value>hdfs://IP:9000/HBase</value>
</property>
<property>
    <name>hbase.cluster.distributed</name>
    <value>true</value>
</property>
<property>
    <name>hbase.zookeeper.quorum</name>
    <value>IP1:2181,IP2:2181,IP3:2181</value>
</property>
<property>
    <name>hbase.master.port</name>
    <value>60000</value>
</property>
<property>
    <name>hbase.master.info.port</name>
    <value>60010</value>
</property>
<property>
    <name>hbase.regionserver.port</name>
    <value>60020</value>
</property>
<property>
    <name>hbase.regionserver.info.port</name>
    <value>60030</value>
</property>
<property>
    <name>hbase.security.authentication</name>
    <value>KERBEROS</value>
</property>
<property>
    <name>hbase.master.keytab.file</name>
    <value>masterkeytab</value>
</property>
<property>
    <name>hbase.regionserver.keytab.file</name>
    <value>regionserverkeytab</value>
</property>
<property>
    <name>hbase.master.kerberos.principal</name>
    <value>masterprincipal</value>
</property>
<property>
    <name>hbase.regionserver.kerberos.principal</name>
    <value>regionserverprincipal</value>
</property>
<property>
    <name>hbase.rpc.engine</name>
    <value>org.apache.hadoop.hbase.ipc.SecureRpcEngine</value>
</property>
<property>
    <name>hbase.ssl.enabled</name>
    <value>true</value>
</property>
<property>
    <name>hbase.superuser</name>
    <value>@HadoopUser</value>
</property>
<property>
    <name>hbase.security.authorization</name>
    <value>true</value>
</property>
<property>
    <name>hbase.coprocessor.master.classes</name>
    <value>org.apache.hadoop.hbase.security.access.AccessController</value>
</property>
<property>
    <name>hbase.coprocessor.region.classes</name>
    <value>org.apache.hadoop.hbase.security.token.TokenProvider,org.apache.hadoop.hbase.security.access.AccessController</value>
</property>

Find my stack overflow question here
http://stackoverflow.com/questions/37782043/hbase-acl-commands-are-too-slow

Thanks,

Kumar

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message