hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Yu <yuzhih...@gmail.com>
Subject Re: Upgrade from 1.1.3 to 1.2.0 failed
Date Wed, 09 Mar 2016 13:58:16 GMT
Can you take a look at data-1 server log around this time frame to see what happened ?

Thanks

> On Mar 9, 2016, at 3:44 AM, Michal Medvecky <medvecky@pexe.so> wrote:
> 
> Hello,
> 
> I upgraded my single hbase master and single hbase regionserver from 1.1.3
> to 1.2.0, by simply stopping both, upgrading packages (i download binary
> packages from hbase.org) and starting them again.
> 
> It did not come up; master is stuck in assigning hbase:meta:
> 
> 2016-03-09 11:28:11,491 INFO
> [staging-aws-hbase-3:16000.activeMasterManager] master.AssignmentManager:
> Processing 1588230740 in state: M_ZK_REGION_OFFLINE
> 2016-03-09 11:28:11,491 INFO
> [staging-aws-hbase-3:16000.activeMasterManager] master.RegionStates:
> Transition {1588230740 state=OFFLINE, ts=1457522891475, server=null} to
> {1588230740 state=OFFLINE, ts=1457522891491,
> server=staging-aws-hbase-data-1.aws.px,16020,1457522034036}
> 2016-03-09 11:28:11,492 INFO
> [staging-aws-hbase-3:16000.activeMasterManager]
> zookeeper.MetaTableLocator: Setting hbase:meta region location in ZooKeeper
> as staging-aws-hbase-data-1.aws.px,16020,1457522034036
> 2016-03-09 11:42:10,611 ERROR [Thread-65] master.HMaster: Master failed to
> complete initialization after 900000ms. Please consider submitting a bug
> report including a thread dump of this process.
> 
> Did I miss something?
> 
> I tried downgrading back to 1.1.3 but later realized this is not supported
> (and does not work of course).
> 
> Thank you
> 
> Michal

Mime
View raw message