hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Yu <yuzhih...@gmail.com>
Subject Re: Thrift server 2 in Hbase
Date Wed, 27 Jan 2016 05:38:17 GMT
Which hbase release are you using ?

There were some relatively recent fixes going into thrift2 server.

Cheers

On Tue, Jan 26, 2016 at 9:12 PM, Rajeshkumar J <rajeshkumarit8292@gmail.com>
wrote:

> There is no update happened in the table I have just created sample table
> with 10 rows and tested this. And I have used below command to start hbase
> thrift server 1
>
> hbase org.apache.hadoop.hbase.thrift.ThriftServer start
>
> And I have used below command to start hbase thrift server 2
>
> hbase org.apache.hadoop.hbase.thrift2.ThriftServer start
>
> Thanks
>
> On Wed, Jan 27, 2016 at 10:35 AM, Ted Yu <yuzhihong@gmail.com> wrote:
>
> > Can you provide a bit more information ?
> >
> > Which hbase release are you using ?
> > In between the two queries, was there any concurrent update to the
> > underlying table ?
> >
> > BTW I assume thrift servers 1 and 2 use the same binary - they just
> resided
> > on different machines.
> >
> > Cheers
> >
> > On Tue, Jan 26, 2016 at 9:02 PM, Rajeshkumar J <
> > rajeshkumarit8292@gmail.com>
> > wrote:
> >
> > > Hi,
> > >
> > >
> > >   I have table named temp in hbase. First I have started the thrift
> > server
> > > 1 and queried the table and also it returns the result.
> > >   Then I have stopped the thrift server 1 and now I have started thrift
> > > server 2 and queried the table with some queries which I have used
> > earlier
> > > but it didn't return any results. Is there any reasons?
> > >
> > > Thanks
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message