hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Yu <yuzhih...@gmail.com>
Subject Re: regions in transition
Date Tue, 22 Dec 2015 16:29:31 GMT
>From RegionListTmpl.jamon :

<%if (onlineRegions != null && onlineRegions.size() > 0) %>
...
<%else>
    <p>Not serving regions</p>
</%if>

The message means that there was no region online on the underlying server.

FYI

On Tue, Dec 22, 2015 at 7:18 AM, Brian Jeltema <bdjeltema@gmail.com> wrote:

> Following up, if I look at the MBase Master UI in the Ambari console I see
> links to
> all of the region servers. If I click on those links, the Region Server
> page comes
> up and in the Regions section, is displays ‘Not serving regions’. I’m not
> sure
> if that means something is disabled, or it just doesn’t have any regions
> to server.
>
> > On Dec 22, 2015, at 6:19 AM, Brian Jeltema <bdjeltema@gmail.com> wrote:
> >
> >>
> >> Can you pick a few regions stuck in transition and check related region
> >> server logs to see why they couldn't be assigned ?
> >
> > I don’t see anything in the region logs relating any regions.
> >
> >>
> >> Which release were you using previously ?
> >
> > HDP 2.1 -> HDP 2.2
> >
> > So is it safe to stop HBase and delete the ZK node?
> >
> >>
> >> Thanks
> >>
> >> On Mon, Dec 21, 2015 at 3:54 PM, Brian Jeltema <bdjeltema@gmail.com>
> wrote:
> >>
> >>> I am doing a cluster upgrade to the HDP 2.2 stack. For some reason,
> after
> >>> the upgrade HBase
> >>> cannot find any regions for existing tables. I believe the HDFS file
> >>> system is OK. But looking at the ZooKeeper
> >>> nodes, I noticed that many (maybe all) of the regions were listed in
> the
> >>> ZooKeeper
> >>> /hbase-unsecure/region-in-transition node. I suspect this could be
> causing
> >>> a problem. Is it
> >>> safe to stop HBase and delete that node?
> >>>
> >>> Thanks
> >>> Brian
> >
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message