hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "聪聪" <175998...@qq.com>
Subject 回复: HBase client and server version is not compatible leadregionserver down
Date Wed, 18 Nov 2015 16:58:43 GMT
Ted:


Because a lot of development is the use of the wrong client, I think about how to avoid.For
example, we even upgrade to 1.0 but they may use 2.0 version.




------------------ 原始邮件 ------------------
发件人: "Ted Yu";<yuzhihong@gmail.com>;
发送时间: 2015年11月18日(星期三) 晚上7:37
收件人: "user@hbase.apache.org"<user@hbase.apache.org>; 

主题: Re: HBase client and server version is not compatible leadregionserver down



See http://hbase.apache.org/book.html#hbase.rolling.upgrade

For example, in Rolling upgrade from 0.98.x to HBase 1.0.0, we state that
it is possible to do a rolling upgrade between hbase-0.98.x and hbase-1.0.0.

Cheers

On Wed, Nov 18, 2015 at 12:22 AM, 聪聪 <175998806@qq.com> wrote:

> We recently found that regionserver down.Later, we found that because the
> client and server version is not compatible.The client version is
> 1.0,server version is 0.98.6.I want to know why this is, and whether there
> is a better protection mechanism.How to avoid this problem, because some
> development will appear this kind of mistake operation.
Mime
  • Unnamed multipart/alternative (inline, 8-Bit, 0 bytes)
View raw message