hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yu Li <car...@gmail.com>
Subject Re: HBase client and server version is not compatible leadregionserver down
Date Thu, 19 Nov 2015 06:53:58 GMT
Second Enis and Heng, suggest to dig deeper into RS log and find the real
reason causing RS crash.

Best Regards,
Yu

On 19 November 2015 at 03:18, Enis Söztutar <enis@apache.org> wrote:

> It is highly unlikely that a client to cause the server side to abort. It
> is possible that due to some other problem the regionservers are aborting.
> The regionservers will reject client connection requests if there is an RPC
> version mismatch.
>
> 1.x and 0.98 client and servers have been tested to be rolling upgrade
> compatible (meaning that older clients can work with newer server versions
> or vice versa).
>
> Enis
>
> On Wed, Nov 18, 2015 at 10:47 AM, Ted Yu <yuzhihong@gmail.com> wrote:
>
> > HBaseAdmin has this method:
> >
> >   public ClusterStatus getClusterStatus() throws IOException {
> >
> > where ClusterStatus has:
> >
> >   public String getHBaseVersion() {
> >
> >     return hbaseVersion;
> >
> > FYI
> >
> > On Wed, Nov 18, 2015 at 8:58 AM, 聪聪 <175998806@qq.com> wrote:
> >
> > > Ted:
> > >
> > >
> > > Because a lot of development is the use of the wrong client, I think
> > about
> > > how to avoid.For example, we even upgrade to 1.0 but they may use 2.0
> > > version.
> > >
> > >
> > >
> > >
> > > ------------------ 原始邮件 ------------------
> > > 发件人: "Ted Yu";<yuzhihong@gmail.com>;
> > > 发送时间: 2015年11月18日(星期三) 晚上7:37
> > > 收件人: "user@hbase.apache.org"<user@hbase.apache.org>;
> > >
> > > 主题: Re: HBase client and server version is not compatible
> > leadregionserver
> > > down
> > >
> > >
> > >
> > > See http://hbase.apache.org/book.html#hbase.rolling.upgrade
> > >
> > > For example, in Rolling upgrade from 0.98.x to HBase 1.0.0, we state
> that
> > > it is possible to do a rolling upgrade between hbase-0.98.x and
> > > hbase-1.0.0.
> > >
> > > Cheers
> > >
> > > On Wed, Nov 18, 2015 at 12:22 AM, 聪聪 <175998806@qq.com> wrote:
> > >
> > > > We recently found that regionserver down.Later, we found that because
> > the
> > > > client and server version is not compatible.The client version is
> > > > 1.0,server version is 0.98.6.I want to know why this is, and whether
> > > there
> > > > is a better protection mechanism.How to avoid this problem, because
> > some
> > > > development will appear this kind of mistake operation.
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message