hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tianying Chang <tych...@gmail.com>
Subject Upgrade application's unit test setup from 0.94 MiniCluster to 1.x
Date Mon, 02 Nov 2015 18:34:49 GMT
Hi,

We currently have 0.94 hbase mini cluster setup to run unit test for our
application. As we upgrade to 1.x, we need to start 1.0 mini hbase cluster
so that we can run application unit test again HBase 1.0.

In the current pom, we need dependency of *hbase-tests* shown as below, to
start a 1.x mini cluster, is only *hbase-testing-util* needed? Is there any
other changes need to be made? Is there any example or guide on this?

Thanks
Tian-Ying

*1.x version*
<dependency>
            <groupId>org.apache.hbase</groupId>
            <artifactId>hbase-testing-util</artifactId>
            <version>1.2.0-SNAPSHOT</version>
            <scope>test</scope>
            <optional>true</optional>
 </dependency>


*0.94 version: *
<dependency>
    <groupId>org.apache.hbase</groupId>
    <artifactId>hbase-tests</artifactId>
    <version>0.94.3.2</version>
    <scope>test</scope>
    <optional>true</optional>
</dependency>

<dependency>
<groupId>org.apache.hbase</groupId>
<artifactId>hbase</artifactId>
<version>0.94.17</version>
<scope>test</scope>
<optional>true</optional>
</dependency>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message