hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From kumar r <kumarc...@gmail.com>
Subject RE: HBase error disabled security features are not available
Date Thu, 05 Nov 2015 03:52:27 GMT
Thanks for the reply,

I have configured with kerberos only. Authentication works fine but authorization and http
authentication not working.

-----Original Message-----
From: "Enis Söztutar" <enis@apache.org>
Sent: ‎05/‎11/‎2015 02:30
To: "hbase-user" <user@hbase.apache.org>
Subject: Re: HBase error disabled security features are not available

You should also configure authentication set to kerberos.

Enis

On Tue, Nov 3, 2015 at 9:00 PM, kumar r <kumarccpp@gmail.com> wrote:

> Yes I have set all this property,
>
> I got user ticket using kinit command and when trying to run *user_permission
> or grant *command in hbase shell, getting this exception
>
> Posted the question is stack overflow in the below link
>
>
> http://stackoverflow.com/questions/33496541/hbase-error-disabled-security-features-are-not-available
>
>
>
> On Wed, Nov 4, 2015 at 10:23 AM, Ted Yu <yuzhihong@gmail.com> wrote:
>
>> Have you set the following config ?
>>
>> hbase.master.keytab.file
>> hbase.master.kerberos.principal
>> hbase.regionserver.keytab.file
>> hbase.regionserver.kerberos.principal
>>
>> Refer to http://hbase.apache.org/book.html for their meaning / sample
>> value.
>>
>> Please show the stack trace of the exception you got.
>>
>> Cheers
>>
>> On Tue, Nov 3, 2015 at 8:43 PM, kumar r <kumarccpp@gmail.com> wrote:
>>
>> > Configured secure HBase-1.1.2 with Hadoop-2.7.1 on Windows. When i
>> enable
>> > authorization referring Configuring HBase Authorization
>> > <
>> >
>> http://www.cloudera.com/content/www/en-us/documentation/archive/cdh/4-x/4-3-2/CDH4-Security-Guide/cdh4sg_topic_8_3.html
>> > >,
>> > getting *ERROR: DISABLED: Security features are not available*
>> exception.
>> >
>> > I have set the authorization configurations as below,
>> >
>> > <property>
>> >      <name>hbase.security.authorization</name>
>> >      <value>true</value>
>> > </property>
>> >
>> > <property>
>> >      <name>hbase.coprocessor.master.classes</name>
>> >
>> >  <value>org.apache.hadoop.hbase.security.access.AccessController</value>
>> > </property>
>> >
>> > <property>
>> >      <name>hbase.coprocessor.region.classes</name>
>> >
>> >
>> <value>org.apache.hadoop.hbase.security.token.TokenProvider,org.apache.hadoop.hbase.security.access.AccessController</value>
>> > </property>
>> >
>> > But HBase Authorization works fine when i tried with HBase-0.98.13
>> > version. Some one help me to enable HBase Authorization in a correct
>> > way.
>> >
>>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message