hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From beeshma r <beeshm...@gmail.com>
Subject Start hbase with replication mode
Date Wed, 21 Oct 2015 16:51:13 GMT
Hi

i just want to hbase as a replication mode.As per documentation zookeeper
must not be managed by HBase

so created below settings

*zookeeper zoo.cfg(/home/beeshma/zookeeper-3.4.6/cfg)*

tickTime=2000
dataDir=/home/beeshma/zookeeper
clientPort=2181
initLimit=5
syncLimit=2

*hbase-site.xml*

<configuration>
<property>
<name>hbase.master</name>
<value>master:9000</value>
</property>
<property>
    <name>hbase.rootdir</name>
    <value>hdfs://localhost:9000/hbase</value>
  </property>
  <property>
    <name>hbase.zookeeper.property.dataDir</name>
    <value>/home/beeshma/zookeeper-3.4.6/conf</value>
  </property>
<!-- Zookeeepr external-->
<property>
  <name>hbase.cluster.distributed</name>
  <value>true</value>
</property>
<!-- Zookeeepr external-->
<property>
<name>hbase.zookeeper.property.clientPort</name>
<value>2181</value>
</property>
<property>
<name>hbase.zookeeper.quorum</name>
<value>localhost</value>
</property>
<!-- Zookeeepr external- -->
  <!-- SEP is basically replication, so enable it -->
  <property>
    <name>hbase.replication</name>
    <value>true</value>
  </property>
  <!-- Source ratio of 100% makes sure that each SEP consumer is actually
       used (otherwise, some can sit idle, especially with small clusters)
-->
  <property>
    <name>replication.source.ratio</name>
    <value>1.0</value>
  </property>
  <!-- Maximum number of hlog entries to replicate in one go. If this is
       large, and a consumer takes a while to process the events, the
       HBase rpc call will time out. -->
  <property>
    <name>replication.source.nb.capacity</name>
    <value>1000</value>
  </property>
  <!-- A custom replication source that fixes a few things and adds
       some functionality (doesn't interfere with normal replication
       usage). -->
  <property>
    <name>replication.replicationsource.implementation</name>
    <value>com.ngdata.sep.impl.SepReplicationSource</value>
  </property>
</configuration>


*in hbase-env.shexport HBASE_MANAGES_ZK=false*

when i start zookeeper and hbase ,i abale to see fallowing confusions
zookeeper started with fallowing specifications
2015-10-21 04:22:13,810 [myid:] - INFO  [main:Environment@100] - Server
environment:java.io.tmpdir=/tmp
2015-10-21 04:22:13,810 [myid:] - INFO  [main:Environment@100] - Server
environment:java.compiler=<NA>
2015-10-21 04:22:13,813 [myid:] - INFO  [main:Environment@100] - Server
environment:os.name=Linux
2015-10-21 04:22:13,814 [myid:] - INFO  [main:Environment@100] - Server
environment:os.arch=amd64
2015-10-21 04:22:13,814 [myid:] - INFO  [main:Environment@100] - Server
environment:os.version=3.11.0-12-generic
2015-10-21 04:22:13,814 [myid:] - INFO  [main:Environment@100] - Server
environment:user.name=beeshma
2015-10-21 04:22:13,814 [myid:] - INFO  [main:Environment@100] - Server
environment:user.home=/home/beeshma
2015-10-21 04:22:13,814 [myid:] - INFO  [main:Environment@100] - Server
environment:user.dir=/home/beeshma/zookeeper-3.4.6/bin
2015-10-21 04:22:13,827 [myid:] - INFO  [main:ZooKeeperServer@755] -
tickTime set to 2000
2015-10-21 04:22:13,827 [myid:] - INFO  [main:ZooKeeperServer@764] -
minSessionTimeout set to -1
2015-10-21 04:22:13,827 [myid:] - INFO  [main:ZooKeeperServer@773] -
maxSessionTimeout set to -1
2015-10-21 04:22:13,893 [myid:] - INFO  [main:NIOServerCnxnFactory@94] -
binding to port 0.0.0.0/0.0.0.0:2181

But Hbase starts with own zookeeper
in hbase zookeeper log
2015-10-21 04:25:12,345 INFO  [main] server.ZooKeeperServer: Server
environment:java.io.tmpdir=/tmp
2015-10-21 04:25:12,345 INFO  [main] server.ZooKeeperServer: Server
environment:java.compiler=<NA>
2015-10-21 04:25:12,345 INFO  [main] server.ZooKeeperServer: Server
environment:os.name=Linux
2015-10-21 04:25:12,345 INFO  [main] server.ZooKeeperServer: Server
environment:os.arch=amd64
2015-10-21 04:25:12,357 INFO  [main] server.ZooKeeperServer: Server
environment:os.version=3.11.0-12-generic
2015-10-21 04:25:12,358 INFO  [main] server.ZooKeeperServer: Server
environment:user.name=beeshma
2015-10-21 04:25:12,358 INFO  [main] server.ZooKeeperServer: Server
environment:user.home=/home/beeshma
2015-10-21 04:25:12,358 INFO  [main] server.ZooKeeperServer: Server
environment:user.dir=/home/beeshma/hbase-0.98.6.1-hadoop2
2015-10-21 04:25:12,423 INFO  [main] server.ZooKeeperServer: tickTime set
to 3000
2015-10-21 04:25:12,423 INFO  [main] server.ZooKeeperServer:
minSessionTimeout set to -1
2015-10-21 04:25:12,423 INFO  [main] server.ZooKeeperServer:
maxSessionTimeout set to 90000
2015-10-21 04:25:12,493 INFO  [main] server.NIOServerCnxnFactory: binding
to port 0.0.0.0/0.0.0.0:2181

Also already  port 0.0.0.0/0.0.0.0:2181 binded with zookeeper so in hbase
fallowing error occuring

*hbase-beeshma-zookeeper-ubuntu.out*

java.net.BindException: Address already in use
    at sun.nio.ch.Net.bind0(Native Method)
    at sun.nio.ch.Net.bind(Net.java:444)
    at sun.nio.ch.Net.bind(Net.java:436)
    at
sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:214)
    at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:74)
    at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:67)
    at
org.apache.zookeeper.server.NIOServerCnxnFactory.configure(NIOServerCnxnFactory.java:95)
    at
org.apache.zookeeper.server.ZooKeeperServerMain.runFromConfig(ZooKeeperServerMain.java:111)
    at
org.apache.hadoop.hbase.zookeeper.HQuorumPeer.runZKServer(HQuorumPeer.java:91)
    at
org.apache.hadoop.hbase.zookeeper.HQuorumPeer.main(HQuorumPeer.java:76)


So what are settings i need to change?


Thanks
Beeshma

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message