hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hbase Janitor <hbasejani...@gmail.com>
Subject Re: regions stuck in transition
Date Mon, 07 Sep 2015 20:45:34 GMT
I'm checking now, but I think there was some kind of network problem during
the time.

I was also asking for future reference =-)

On Mon, Sep 7, 2015 at 4:42 PM, Ted Yu <yuzhihong@gmail.com> wrote:

> For the region with corrupt hfile, regardless how many times it is
> attempted to be opened, failure to open would result, right ?
>
>
>
> > On Sep 7, 2015, at 1:36 PM, Hbase Janitor <hbasejanitor@gmail.com>
> wrote:
> >
> > Is there any way to make region in transition try again if the initial
> try
> > failed?
> >
> > On Mon, Sep 7, 2015 at 3:22 PM, Hbase Janitor <hbasejanitor@gmail.com>
> > wrote:
> >
> >> looks like I have a corrupt hfile, probably related to the replication
> >> problems i'm having now.
> >>
> >> Thanks for the help!
> >>
> >>> On Mon, Sep 7, 2015 at 3:16 PM, Ted Yu <yuzhihong@gmail.com> wrote:
> >>>
> >>> After timeout, the master would re-assign those regions.
> >>>
> >>> Can you check region server log to see why region open failed ?
> >>> Was there any HFile which couldn't be opened ?
> >>>
> >>> Pastebinning log snippet if needed.
> >>>
> >>> Cheers
> >>>
> >>> On Mon, Sep 7, 2015 at 11:24 AM, Hbase Janitor <hbasejanitor@gmail.com
> >
> >>> wrote:
> >>>
> >>>> Hi,
> >>>>
> >>>> I have another problem, on my hbase 1.0 cluster I have a lot of
> regions
> >>>> that seem to be stuck in transition.  I saw a exception attempting to
> >>>> connect to zookeeper around the time they were hung.
> >>>>
> >>>> Is there a way to force them to retry?
> >>
> >>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message