hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Akmal Abbasov <akmal.abba...@icloud.com>
Subject Re: HBase WebUI is not responding
Date Mon, 14 Sep 2015 22:02:48 GMT
Yes, hbase shell is functioning properly.
Actually WebUI is working, the only thing which isn’t working is the main page,  http://hbase-test-master2:60010/master-status
<http://hbase-test-master2:60010/master-status>
The server isn’t responding, and I’m getting the following messages in master logs
2015-09-14 21:56:29,282 WARN  [1407002739@qtp-1651370800-5] client.HConnectionManager$HConnectionImplementation:
Checking master connection
com.google.protobuf.ServiceException: java.net.SocketTimeoutException: Call to hbase-test-master2/192.168.0.54:60000
failed because java.net.SocketTimeoutException: 60000 millis timeout while waiting for channel
to be ready for read. ch : java.nio.channels.SocketChannel[connected local=/192.168.0.54:33876
remote=hbase-test-master2/192.168.0.54:60000]
So there is some info in main page of the WebUI which isn’t responding, any insights what
it could be?

Thanks.


> On 14 Sep 2015, at 15:09, Ted Yu <yuzhihong@gmail.com> wrote:
> 
> Can you check master log for the period when you accessed master web UI ?
> Does hbase shell function properly ?
> 
> Thanks
> 
> 
> 
>> On Sep 14, 2015, at 4:36 AM, Akmal Abbasov <akmal.abbasov@icloud.com> wrote:
>> 
>> Hi all,
>> I’m having problems with accessing to HBase WebUI on active master node, while
I still can access to the WebUI of the standby master.
>> I’ve checked the state of HBase using hbase hbck, and it is in consistent state.
>> Checked the node which holds hbase:meta table, the snippet from its logs
>> 2015-09-09 02:41:02,481 INFO  [PostOpenDeployTasks:1588230740] zookeeper.ZooKeeperNodeTracker:
Setting hbase:meta region location in ZooKeeper as test-rs5,60020,1441628944044
>> 2015-09-09 02:41:02,509 INFO  [PostOpenDeployTasks:1588230740] regionserver.HRegionServer:
Finished post open deploy task for hbase:meta,,1.1588230740
>> 2015-09-09 02:41:02,522 DEBUG [RS_OPEN_META-test-rs5:60020-0] handler.OpenRegionHandler:
Opened hbase:meta,,1.1588230740 on test-rs5,60020,1441628944044
>> I’m using hadoop-2.5.1 with hbase-0.98.7-hadoop2.
>> What could be wrong in this case?
>> 
>> Thanks.


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message