hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From donmai <dood...@gmail.com>
Subject Re: readAtOffset error when reading from HFiles
Date Tue, 12 May 2015 15:50:18 GMT
Actually, looking deeper into it, things don't seem to be making sense.

The error message is this: Caused by: java.io.IOException: Positional read
of 65723 bytes failed at offset 394218 (returned 16384)

As such, I try to do a read for 65723 bytes using the tool to see if it
fails at that offset:

hbase org.apache.hadoop.hbase.io.hfile.HFile -w 65723 -f
s3://hbase/data/default/usertable/5cce51bd0bcc8f7507c7e594b73d2d15/family/ec3d1516dba0447e875d489f3ad8bdc0

This results in no output other than:

INFO  [main] s3n.S3NativeFileSystem: Stream for key
'bleh2/data/default/usertable/5cce51bd0bcc8f7507c7e594b73d2d15/family/ec3d1516dba0447e875d489f3ad8bdc0'
seeking to position '1693329'

Am I using the HFIle command correctly?

On Tue, May 12, 2015 at 11:09 AM, donmai <doodnet@gmail.com> wrote:

> Thanks Ted, this actually helped me out alot! I'm running 0.98.6 and was
> able to determine that the HFiles are perfectly okay and can be scanned
> through without issue - it looks like there's something else going on,
> since after a compaction everything works...
>
> On Tue, May 12, 2015 at 9:55 AM, Ted Yu <yuzhihong@gmail.com> wrote:
>
>> What release of hbase are you using ?
>>
>> Please read http://hbase.apache.org/book.html#hfile where you can find
>> description about HFile tool. This tool would allow you to investigate
>> given HFile.
>>
>> Cheers
>>
>> On Tue, May 12, 2015 at 6:02 AM, donmai <doodnet@gmail.com> wrote:
>>
>> > Hi,
>> >
>> > I'm getting this error when trying to read from HFiles:
>> >
>> > http://pastebin.com/SJci7uQM
>> >
>> > Any idea what's going on here?
>> >
>> > Thanks!
>> >
>>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message