hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From apa...@borkbork.net
Subject Re: Issues with import from 0.92 into 0.98
Date Wed, 27 May 2015 17:23:28 GMT
On Wed, May 27, 2015, at 11:35 AM, Dave Latham wrote:
> Sounds like quite a puzzle.
> You mentioned that you can read data written through manual Puts from
> the shell - but not data from the Import.  There must be something
> different about the data itself once it's in the table.  Can you
> compare a row that was imported to a row that was manually written -
> or show them to us?

Hmph, I may have spoken too soon. I know I tested this at one point and
it worked, but now I'm getting different results:

On the new cluster, I created a duplicate test table:
hbase(main):043:0> create 'content3', {NAME => 'x', BLOOMFILTER =>
'NONE', MIN_VERSIONS => '0', TTL => '2147483647', BLOCKSIZE => '65536',
IN_MEMORY => 'false', BLOCKCACHE => 'true'}

Then I pull some data from the imported table:
hbase(main):045:0> scan 'content', {LIMIT=>1,
ROW                                  COLUMN+CELL                         
column=x:twitter:username, timestamp=1424775595345, value=BERITA &
Then put it:
hbase(main):046:0> put
'x:twitter:username', 'BERITA & INFORMASI!'

But then when I query it, I see that I've lost the column qualifier
hbase(main):046:0> scan 'content3'
ROW                                  COLUMN+CELL                         
 A:9223370612089311807:twtr:570133798827921408 column=x:twitter,
 timestamp=1432745301788, value=BERITA & INFORMASI!                      
Even though I'm missing one of the qualifiers, I can at least filter on
columns in this sample table.

So now I'm even more baffled :(


View raw message