hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Solomon Duskis <sdus...@gmail.com>
Subject Re: Upgrade client to 1.0.0 - Dependency on legacy Guava Version ?
Date Wed, 01 Apr 2015 13:55:27 GMT
I've run into this as well.  I ended up using the mavnen shading tool to
work around this.  Hadoop uses an older version of guava, IIRC.  Changing
this is non trivial, although I think it's super important to do.

-Solomon

On Wed, Apr 1, 2015 at 9:35 AM, Enrico Olivelli - Diennea <
enrico.olivelli@diennea.com> wrote:

> Hi all,
> I'm going to upgrade my Java client  from version 0.94 to version 1.0.0.
> The new 1.0.0 client needs version 15.0 of Guava (due to a dependency of a
> deprecated constructor of StopWatch,
> http://docs.guava-libraries.googlecode.com/git/javadoc/com/google/common/base/Stopwatch.html
> ), while I'm using the latest version.
> This is a real showstopper for me
> Any suggestion ?
>
>
> Enrico Olivelli
> Software Development Manager @Diennea
> Tel.: (+39) 0546 066100 - Int. 925
> Viale G.Marconi 30/14 - 48018 Faenza (RA)
>
> MagNews - E-mail Marketing Solutions
> http://www.magnews.it<http://www.magnews.it/>
> Diennea - Digital Marketing Solutions
> http://www.diennea.com<http://www.diennea.com/>
>
>
>
>
> ________________________________
> Iscriviti alla nostra newsletter per rimanere aggiornato su digital ed
> email marketing! http://www.magnews.it/newsletter/
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message