hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Yu <yuzhih...@gmail.com>
Subject Re: Rebalancing after manual region move
Date Wed, 29 Apr 2015 18:35:42 GMT
In the upcoming 1.1.0 release, the following would make balancer state
inspection more user-friendly:
HBASE-13222 Provide means of non-destructive balancer inspection

FYI

On Wed, Apr 29, 2015 at 4:11 AM, Dejan Menges <dejan.menges@gmail.com>
wrote:

> Hi Jean-Marc,
>
> Ok, that's what I thought too, just wasn't sure as I didn't see any error
> anywhere, neither something happening when I run balancer, so it's good
> then :)
>
> Thanks a lot!
> Dejan
>
> On Wed, Apr 29, 2015 at 12:52 PM Jean-Marc Spaggiari <
> jean-marc@spaggiari.org> wrote:
>
> > Hi Dejan,
> >
> > Most probably because the cluster is balanced enough?
> >
> > You can run the balancer from the shell and look in the logs to see
> what's
> > the outcome.
> >
> > Simply type "hbase shell" and then "balancer". It will also return the
> > state of the balancer (true for active, false of passive).
> >
> > JM
> >
> > 2015-04-29 6:46 GMT-04:00 Dejan Menges <dejan.menges@gmail.com>:
> >
> > > Hi,
> > >
> > > During investigation of some issues during hotspoting we were moving
> some
> > > regions to different region servers. However, now I see that balancer
> is
> > > not affecting those regions anymore - they 'stick' to those servers. Is
> > > there a way to force rebalancing in case like this?
> > >
> > > Thanks!
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message