hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sridhararao mutluri <drm...@hotmail.com>
Subject Hbase 0.98 Distributed Mode with hadoop 2.6 HA:Issues of Hbase
Date Tue, 07 Apr 2015 12:16:02 GMT
Hi Team,
I am trying to use hbase 0.98 distributed mode with zk 3.4.6 & hadoop ha 2.6.(JDK 1.8)
I am having following issue and little help in google pages also
I tried to start zk first after clearing zk data dir and tried to start master first and rs
later and no luck 
I used mycluster/hbase in hbase-site.xml and no luck to me.tried to put hdfs-site.xml/core-site.xml
in $Hbase_home/conf also.
I noticed all hadoop.*jars in $HBASE_HOME/lib are 2.2 of hadoop where as we are using 2.6
and tried to copy those hadoop jars ..but no luck.
A New new error is coming:

hbase(main):002:0> create 'cars', 'vi'
ERROR: java.io.IOException: Table Namespace Manager not ready yet, try again later       
at org.apache.hadoop.hbase.master.HMaster.getNamespaceDescriptor(HMaster.java:3179)      
 at org.apache.hadoop.hbase.master.HMaster.createTable(HMaster.java:1735)        at org.apache.hadoop.hbase.master.HMaster.createTable(HMaster.java:1774)
       at org.apache.hadoop.hbase.protobuf.generated.MasterProtos$MasterService$2.callBlockingMethod(MasterProtos.java:40470)
       at org.apache.hadoop.hbase.ipc.RpcServer.call(RpcServer.java:2027)        at org.apache.hadoop.hbase.ipc.CallRunner.run(CallRunner.java:98)
       at org.apache.hadoop.hbase.ipc.FifoRpcScheduler$1.run(FifoRpcScheduler.java:74)   
    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)        at java.util.concurrent.FutureTask.run(FutureTask.java:266)
       at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
       at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
       at java.lang.Thread.run(Thread.java:745)ZK are running on 3 servers.I tired to stop
hbase and then stopped zk in 3 clusters and cleared zk data and started fresh.
My bash_profile on classpath:export CLASSPATH=$CLASSPATH:/home/hadoop/hadoop-2.6.0/lib/*:.export
CLASSPATH=$CLASSPATH:/home/hadoop/hbase-0.98.4/lib/*:.
my hbase_site.xml
<property>            <name>hbase.rootdir</name>            <value>hdfs://mycluster/hbase</value>
      </property>       <property>
 and hadoop core-site is same.
Any incompatibility between JDK1.8 with hbase or hadoop 2.6?
Please suggest any solution.
Thanks,Sridhar

 		 	   		  
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message