hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From lars hofhansl <la...@apache.org>
Subject Re: Root Region Error with hbase 0.98.4
Date Mon, 23 Mar 2015 03:46:00 GMT
Did you wipe everything before you ran your code against 0.94.
0.96 and later no longer the -ROOT- region. If you start from scratch with 0.94 it will create
the necessary ZK state for you (including the -ROOT- node).

You need to wipe _everything_ HDFS, and the Zookeeper state (rmr the /hbase znode, or wipe
the ZK state directory on all nodes)


-- Lars



----- Original Message -----
From: Nishanth S <nishanth.2884@gmail.com>
To: user <user@hbase.apache.org>
Cc: 
Sent: Thursday, March 19, 2015 11:00 AM
Subject: Root Region Error with hbase 0.98.4

Hello,

I am running  a ycsb instance to insert data into  hbase.All was well when
this was against hbase 0.96.1.Now I am trying to run the same program to
another cluster which is configured with  hbase 0.98.4.I  get the below
error on the client side.Could some one help me with this?.


The znode for the -ROOT- region doesn't exist!

Thanks,
Nishan

Mime
View raw message