hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ocassano <ocass...@staff.voo.be>
Subject Regionserver won't start
Date Thu, 26 Mar 2015 07:43:57 GMT


Hello everyone,

I’m facing a very strange situation with my test cluster.

Several services are up and running, and I would like to start HBase.
HBase master starts well, but impossible to start any regionserver.

When I try to start one manually, I get this error:

2015-03-23 16:24:32,379 ERROR [main] regionserver.HRegionServerCommandLine:
Region server exiting
java.lang.RuntimeException: Failed suppression of fs shutdown hook:
org.apache.hadoop.fs.FileSystem$Cache$ClientFinalizer@3d135554
at
org.apache.hadoop.hbase.regionserver.ShutdownHook.suppressHdfsShutdownHook(ShutdownHook.java:204)
at
org.apache.hadoop.hbase.regionserver.ShutdownHook.install(ShutdownHook.java:84)
at
org.apache.hadoop.hbase.regionserver.HRegionServer.startRegionServer(HRegionServer.java:2466)
at
org.apache.hadoop.hbase.regionserver.HRegionServer.startRegionServer(HRegionServer.java:2450)
at
org.apache.hadoop.hbase.regionserver.HRegionServerCommandLine.start(HRegionServerCommandLine.java:62)
at
org.apache.hadoop.hbase.regionserver.HRegionServerCommandLine.run(HRegionServerCommandLine.java:85)
at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:70)
at
org.apache.hadoop.hbase.util.ServerCommandLine.doMain(ServerCommandLine.java:126)
at
org.apache.hadoop.hbase.regionserver.HRegionServer.main(HRegionServer.java:2501)

Zookeeper server is up and running with the default configuration, but is
logging this every minutes:

2015-03-23 16:38:32,269 - WARN
[NIOServerCxn.Factory:0.0.0.0/0.0.0.0:2181:NIOServerCnxn@357] - caught end
of stream exception
EndOfStreamException: Unable to read additional data from client sessionid
0x0, likely client has closed socket
at org.apache.zookeeper.server.NIOServerCnxn.doIO(NIOServerCnxn.java:228)
at
org.apache.zookeeper.server.NIOServerCnxnFactory.run(NIOServerCnxnFactory.java:208)
at java.lang.Thread.run(Thread.java:745)

Could this be linked to my HBase regionserver issue? Any other idea?
Where could I search for any extra log information?

Thank you.

Regards,
Orlando




--
View this message in context: http://apache-hbase.679495.n3.nabble.com/Regionserver-won-t-start-tp4069642.html
Sent from the HBase User mailing list archive at Nabble.com.

Mime
View raw message