hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shahab Yunus <shahab.yu...@gmail.com>
Subject Re: Behavior of Split method in HBaseAdmin
Date Wed, 04 Feb 2015 23:47:04 GMT
Thank for the reply Stack.

What exactly should be I looking for? I checked the logs and I don't see
any error, 'can't, 'don't or 'fail' kind of message. What kind of error or
text?

I do see stuff like:
2015-02-04 18:16:25,754 INFO org.apache.hadoop.hbase.master.RegionStates:
Transitioned *null* to {f9cea11544eb80b6aa7c3f5a2fe75181
state=SPLITTING_NEW, ts=1423091785754,
server=ip-10-12-0-111.vf1.internal,60020,1422918135701}


Regards,
Shahab

On Wed, Feb 4, 2015 at 3:07 PM, Stack <stack@duboce.net> wrote:

> See master log when split call comes in. It will say why the split did not
> happen.
> St.Ack
>
> On Wed, Feb 4, 2015 at 12:04 PM, Shahab Yunus <shahab.yunus@gmail.com>
> wrote:
>
> > If we programmatically split a table by async method in HBaseAdmin class
> > and even after waiting for quite a while, the split does not happen
> (there
> > is no difference in number of regions before and after the split call)
> and
> > there is no error or an exception either, does it mean that there is
> > something wrong or is there a valid scenario foe this behavior as well?
> >
> > I am providing the split point as well.
> >
> > Cdh5.3.0 is the version.
> >
> > Thanks.
> >
> > Regards,
> > Shahab
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message