hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kiran Kumar.M.R" <Kiran.Kumar...@huawei.com>
Subject RE: How to configure HTTPS for HBase servers web browser?
Date Fri, 14 Nov 2014 02:20:03 GMT
Hi Rohith,

1. To enable https mode for web UI, you need to configure "hadoop.ssl.enabled"  in 0.98.x
 "hbase.ssl.enabled" in trunk version.
2.  webUI ports configured in "hbase.regionserver.info.port" will now work over https. Ensure
that you are given https:// in URL
     If you give http:// it will not redirect
3. Steps for installing SSL certificate and keystore needed for HTTPS can be referred from
Hadoop HTTPS setup guide.


From: Rohith Sharma K S [rohithsharmaks@huawei.com]
Sent: 13 November 2014 20:00
To: user@hbase.apache.org
Subject: How to configure HTTPS for HBase servers web browser?


    I am setting up Hadoop + HBase cluster in https mode for web access. For Hadoop cluster
, I am able to set up.

But for HBase , I could not find document or configurations to setting up HBase cluster in
HTTPS mode.  I read some document for setting up HBase REST API with SSL and WebHBase with

Does HBase support  configuring HTTPS for accessing HMaster and RegionServer web UI?

Thanks & Regards
Rohith Sharma K S

This e-mail and its attachments contain confidential information from HUAWEI, which is intended
only for the person or entity whose address is listed above. Any use of the information contained
herein in any way (including, but not limited to, total or partial disclosure, reproduction,
or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive
this e-mail in error, please notify the sender by phone or email immediately and delete it!
View raw message