hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Esteban Gutierrez <este...@cloudera.com>
Subject Re: No IPC Handlers showing up in Web UI
Date Fri, 31 Oct 2014 05:03:28 GMT
Hi Patrick,

That is very interesting. Are you using coprocessors? is there anything
else un-common in your environment, e.g. SELinux on, a  Java 8 or limited
OS resources? If you experience this again is there any chance for you to
upload a jstack of the HBase master process to pastebin or gist?

cheers,
esteban.


--
Cloudera, Inc.


On Thu, Oct 30, 2014 at 3:14 PM, Patrick Dignan <pdignan@hubspot.com> wrote:

> There don't seem to be any exceptions related to this, except maybe this:
> 2014-10-29 21:05:59,664 WARN org.apache.hadoop.ipc.HBaseServer: IPC Server
> listener on 60020: readAndProcess threw exception java.io.IOException:
> Connection reset by peer. Count of bytes read: 0
>
> Accessing from the URLs in the Tasks section does not work either.  No
> errors show up in the log if I reload the page a few times.  There's no
> proxy causing issues.
>
> On Thu, Oct 30, 2014 at 6:04 PM, Esteban Gutierrez <esteban@cloudera.com>
> wrote:
>
> > Hi Patrick,
> >
> > Have you tried to access directly via any of the URLs from the Tasks
> > section? e.g. http://<regionserver>:<port>/rs-status?filter=all or
> > http://<regionserver>:<port>/rs-status?filter=handler
> > do you see any error in the logs if you reload the page a couple of
> times?
> > Another possibility is that you are behind a proxy and that might be
> > causing an odd behavior.
> >
> > esteban.
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message