hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nishanth S <nishanth.2...@gmail.com>
Subject Re: Connecting via API to a remote HBASE installation
Date Sun, 26 Oct 2014 16:15:54 GMT
Can you telnet to  port 2181 and 60020 on  the remote cluster if you are
running default ports.I had a similar issue in the past where there was
firewall.

Thanks,
Nishanthon

On Sun, Oct 26, 2014 at 9:39 AM, Ted Yu <yuzhihong@gmail.com> wrote:

> Is hbase-site.xml corresponding to your cluster on the classpath of your
> Windows program ?
>
> Cheers
>
> On Sun, Oct 26, 2014 at 8:08 AM, Sznajder ForMailingList <
> bs4mailinglist@gmail.com> wrote:
>
> > Hi
> >
> > I am running some code from windows (java)
> > and I would like to connect to the HBASE 0.98.5 installed on a remote
> > cluster (pseudodistributed mode)
> >
> > The UI gives me the following info:
> >
> > Software AttributesAttribute NameValueDescriptionHBase
> > Version0.98.5-hadoop2,
> > rUnknownHBase version and revisionHBase CompiledMon Aug 4 23:58:06 PDT
> > 2014, apurtellWhen HBase version was compiled and by whomHadoop
> > Version2.2.0,
> > r1529768Hadoop version and revisionHadoop Compiled2013-10-07T06:28Z,
> > hortonmuWhen Hadoop version was compiled and by whomZookeeper Quorum
> > localhost:2181Addresses of all registered ZK servers. For more, see zk
> dump
> > <http://lnx-apollo.haifa.ibm.com:60010/zk.jsp>.HBase Root Directory
> > hdfs://localhost:8020/hbaseLocation of HBase home directoryHMaster Start
> > TimeWed Sep 03 16:53:19 GMT+02:00 2014Date stamp of when this HMaster was
> > startedHMaster Active TimeWed Sep 03 16:53:19 GMT+02:00 2014Date stamp of
> > when this HMaster became activeHBase Cluster ID
> > 950d5ca3-a174-482c-9b6e-3c858d06f44fUnique identifier generated for each
> > HBase clusterLoad average2.00Average number of regions per regionserver.
> > Naive computation.Coprocessors[]Coprocessors currently loaded by the
> master
> >
> >
> > However when connecting from my code with the following code:
> >         Configuration conf = HBaseConfiguration.create();
> >         conf.set(HBASE_CONFIGURATION_ZOOKEEPER_QUORUM, name);
> >         conf.set(HBASE_CONFIGURATION_ZOOKEEPER_CLIENTPORT, "8020");
> >         admin = new HBaseAdmin(conf);
> >
> >
> > I get the following:
> >
> > java.net.ConnectException: Connection refused: no further information
> >     at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)
> >     at
> > sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:585)
> >     at
> >
> >
> org.apache.zookeeper.ClientCnxnSocketNIO.doTransport(ClientCnxnSocketNIO.java:286)
> >     at
> org.apache.zookeeper.ClientCnxn$SendThread.run(ClientCnxn.java:1035)
> >
> >
> > what do I miss, pelase?
> >
> > Benjamin
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message