hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Yu <yuzhih...@gmail.com>
Subject Re: Pig 0.11 cannot work with HBase 0.98
Date Thu, 16 Oct 2014 08:04:38 GMT
See https://issues.apache.org/jira/browse/HBASE-6658

See this thread as well:
http://search-hadoop.com/m/T9Y7N1zRrGX1/Writablebytearraycomparable+hbase&subj=Re+Pig+cannot+load+data+using+hbasestorage

Cheers

On Oct 16, 2014, at 12:03 AM, Ramon Wang <ramon@appannie.com> wrote:

> Hi Guys
> 
> We are recently trying to upgrade our HBase from 0.94 to 0.98, our original
> PIG setup seems not work with the new HBase anymore, it throws the
> following class not found exception:
> 
> java.lang.NoClassDefFoundError:
> org/apache/hadoop/hbase/filter/WritableByteArrayComparable
> at java.lang.Class.forName0(Native Method)
> 
> I checked the source code of HBase 0.98, there seems no such a class
> WritableByteArrayComparable for 0.98, any thoughts? Thanks!
> 
> Cheers
> Ramon

Mime
  • Unnamed multipart/alternative (inline, 7-Bit, 0 bytes)
View raw message