hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Yu <yuzhih...@gmail.com>
Subject Re: The default hbase.regionserver.info.port doesn't work
Date Thu, 04 Sep 2014 00:59:10 GMT
I used your command to start master (using trunk):

$ lsof -n -i4TCP:16010
COMMAND   PID USER   FD   TYPE             DEVICE SIZE/OFF NODE NAME
java    39528  tyu  178u  IPv6 0xd5c4ef153af26eff      0t0  TCP *:16010
(LISTEN)

For region server:

$ bin/hbase regionserver start
2014-09-03 17:57:37,980 INFO  [main] util.VersionInfo: HBase 2.0.0-SNAPSHOT
2014-09-03 17:57:37,981 INFO  [main] util.VersionInfo: Subversion
git://TYus-MacBook-Pro.local/Users/tyu/trunk -r
1a6eea335f16f92e24834369cd98ea01a60b2db7
2014-09-03 17:57:37,981 INFO  [main] util.VersionInfo: Compiled by tyu on
Wed Sep  3 15:44:16 PDT 2014
2014-09-03 17:57:38,324 WARN  [main] regionserver.HRegionServerCommandLine:
Not starting a distinct region server because hbase.cluster.distributed is
false

Is this what you saw ?


On Wed, Sep 3, 2014 at 5:52 PM, tobe <tobeg3oogle@gmail.com> wrote:

> I clone the latest code from git://git.apache.org/hbase.git and run `mvn
> clean package -DskipTests` to compile. Not change anything and run
> `./bin/hbase master start`. I have tried in several machines. Could you
> have a try or tell me what's wrong with my procedures? Now we're using
> 0.94.11 and it doesn't have this problem.
>
>
> On Wed, Sep 3, 2014 at 10:54 PM, Ted Yu <yuzhihong@gmail.com> wrote:
>
> > Which release are you running ?
> > If you're running trunk build, from HConstants.java :
> >
> >   public static final int DEFAULT_MASTER_INFOPORT = 16010;
> >
> > Cheers
> >
> >
> > On Wed, Sep 3, 2014 at 7:03 AM, tobe <tobeg3oogle@gmail.com> wrote:
> >
> > > It's a little wired when I ran the standalone HBase cluster from
> trunk. I
> > > notice that the default RegionServer info port is not 16010.
> > >
> > > And when I explicitly set hbase.regionserver.info.port, it doesn't
> work.
> > It
> > > changes every time I run.
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message