hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sean Busbey <bus...@cloudera.com>
Subject Re: HBase 0.98.6.1 maven dependency
Date Tue, 30 Sep 2014 15:31:28 GMT
For 0.98.x you should use hbase - client.

See the FAQ item on updating a maven managed project from 0.94 to 0.98:

http://hbase.apache.org/book.html#d0e22846

-- 
Sean
On Sep 30, 2014 7:20 AM, "innowireless TaeYun Kim" <
taeyun.kim@innowireless.co.kr> wrote:

> Hi,
>
>
>
> I'm relatively new to HBase and maven.
>
> Currently I'm trying to add dependency for hbase-0.98.6.1-hadoop2.jar to my
> application.
>
> But when I run 'mvn package' after adding the dependency,  it fails with
> the
> following error:
>
>
>
> [ERROR] Failed to execute goal on project MyApp: Could not resolve
> dependencies for project
> com.innowireless.xcapvuze:MyApp:jar:0.0.1-SNAPSHOT:
> Failure to find org.apache.hbase:hbase:jar:0.98.6.1-hadoop2 in
> http://repo.maven.apache.org/maven2 was cached in the local repository,
> resolution will not be reattempted until the update interval of central has
> elapsed or updates are forced -> [Help 1]
>
>
>
> 'mvn package -U' also failed.
>
>
>
> When I inspected the local repository in
> .m2\repository\org\apache\hbase\hbase\0.98.6.1-hadoop2, there was no jar
> file, while 0.94.6 directory has one.
>
> How can I get the 0.98.6.1 jar?
>
> Should I build it myself?
>
> Or should I add each 'component' jars (hbase-client, hbase-common,
> hbase-protocol.) to the dependency?
>
>
>
> Thank you.
>
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message