hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Yu <yuzhih...@gmail.com>
Subject Re: The default hbase.regionserver.info.port doesn't work
Date Thu, 04 Sep 2014 01:44:02 GMT
16010 is the default info port. 

Cheers

On Sep 3, 2014, at 6:13 PM, tobe <tobeg3oogle@gmail.com> wrote:

> That's wired. I get nothing with `lsof -n -i4TCP:16010`.
> 
> root@emacscode:/opt/hbase/bin# lsof -n -i4TCP:16010
> root@emacscode:/opt/hbase/bin# netstat -nltup
> Active Internet connections (only servers)
> Proto Recv-Q Send-Q Local Address           Foreign Address
> State       PID/Program name
> tcp        0      0 0.0.0.0:22              0.0.0.0:*
> LISTEN      637/sshd
> tcp6       0      0 :::2181                 :::*
> LISTEN      742/java
> tcp6       0      0 :::16010                :::*
> LISTEN      742/java
> tcp6       0      0 :::2222                 :::*
> LISTEN      3297/docker
> tcp6       0      0 :::80                   :::*
> LISTEN      3297/docker
> tcp6       0      0 127.0.0.1:55925         :::*
> LISTEN      742/java
> tcp6       0      0 :::22                   :::*
> LISTEN      637/sshd
> tcp6       0      0 :::57944                :::*
> LISTEN      742/java
> root@emacscode:/opt/hbase/bin# curl 127.0.0.1:16010
> root@emacscode:/opt/hbase/bin# curl 127.0.0.1:57944
> <!--
> /**
> * Licensed to the Apache Software Foundation (ASF) under one
> * or more contributor license agreements.  See the NOTICE file
> * distributed with this work for additional information
> * regarding copyright ownership.  The ASF licenses this file
> * to you under the Apache License, Version 2.0 (the
> * "License"); you may not use this file except in compliance
> * with the License.  You may obtain a copy of the License at
> *
> *     http://www.apache.org/licenses/LICENSE-2.0
> *
> * Unless required by applicable law or agreed to in writing, software
> * distributed under the License is distributed on an "AS IS" BASIS,
> * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
> * See the License for the specific language governing permissions and
> * limitations under the License.
> */
> -->
> <meta HTTP-EQUIV="REFRESH" content="0;url=/master-status"/>
> 
> 57944 is the HMaster info port, right?
> 
> 
> On Thu, Sep 4, 2014 at 8:59 AM, Ted Yu <yuzhihong@gmail.com> wrote:
> 
>> I used your command to start master (using trunk):
>> 
>> $ lsof -n -i4TCP:16010
>> COMMAND   PID USER   FD   TYPE             DEVICE SIZE/OFF NODE NAME
>> java    39528  tyu  178u  IPv6 0xd5c4ef153af26eff      0t0  TCP *:16010
>> (LISTEN)
>> 
>> For region server:
>> 
>> $ bin/hbase regionserver start
>> 2014-09-03 17:57:37,980 INFO  [main] util.VersionInfo: HBase 2.0.0-SNAPSHOT
>> 2014-09-03 17:57:37,981 INFO  [main] util.VersionInfo: Subversion
>> git://TYus-MacBook-Pro.local/Users/tyu/trunk -r
>> 1a6eea335f16f92e24834369cd98ea01a60b2db7
>> 2014-09-03 17:57:37,981 INFO  [main] util.VersionInfo: Compiled by tyu on
>> Wed Sep  3 15:44:16 PDT 2014
>> 2014-09-03 17:57:38,324 WARN  [main] regionserver.HRegionServerCommandLine:
>> Not starting a distinct region server because hbase.cluster.distributed is
>> false
>> 
>> Is this what you saw ?
>> 
>> 
>> On Wed, Sep 3, 2014 at 5:52 PM, tobe <tobeg3oogle@gmail.com> wrote:
>> 
>>> I clone the latest code from git://git.apache.org/hbase.git and run `mvn
>>> clean package -DskipTests` to compile. Not change anything and run
>>> `./bin/hbase master start`. I have tried in several machines. Could you
>>> have a try or tell me what's wrong with my procedures? Now we're using
>>> 0.94.11 and it doesn't have this problem.
>>> 
>>> 
>>> On Wed, Sep 3, 2014 at 10:54 PM, Ted Yu <yuzhihong@gmail.com> wrote:
>>> 
>>>> Which release are you running ?
>>>> If you're running trunk build, from HConstants.java :
>>>> 
>>>>  public static final int DEFAULT_MASTER_INFOPORT = 16010;
>>>> 
>>>> Cheers
>>>> 
>>>> 
>>>> On Wed, Sep 3, 2014 at 7:03 AM, tobe <tobeg3oogle@gmail.com> wrote:
>>>> 
>>>>> It's a little wired when I ran the standalone HBase cluster from
>>> trunk. I
>>>>> notice that the default RegionServer info port is not 16010.
>>>>> 
>>>>> And when I explicitly set hbase.regionserver.info.port, it doesn't
>>> work.
>>>> It
>>>>> changes every time I run.
>> 

Mime
View raw message