hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jimmy Xiang <jxi...@cloudera.com>
Subject Re: Region stuck in Transition FAILED_OPEN after upgrade to HBase0.98
Date Wed, 30 Jul 2014 02:45:10 GMT
What's your setting hbase.assignment.timeout.management? Region is
FAILED_OPEN state usually needs some manual fix, such as assign from hbase
shell.


On Tue, Jul 29, 2014 at 6:06 PM, anil gupta <anilgupta84@gmail.com> wrote:

> Hi Ted,
>
> It seems like the problem self healed. Is there any timeout for
> region_in_transition that led to this fix? Now, UI show's everything is
> good.
>
> Thanks,
> Anil Gupta
>
>
> On Tue, Jul 29, 2014 at 6:01 PM, Ted Yu <yuzhihong@gmail.com> wrote:
>
> > Can you pastebin snippet of master log pertaining to this region ?
> >
> > Cheers
> >
> >
> > On Tue, Jul 29, 2014 at 5:51 PM, anil gupta <anilgupta84@gmail.com>
> wrote:
> >
> > > Hi All,
> > >
> > > We recently upgrade our cluster from 0.94 to HBase0.98(cdh5.1). All the
> > > tables are working fine except one table with 0.94.
> > > One of the region has been stuck in transition since our upgrade.
> > >
> > > I see following HMaster UI:
> > >
> > >
> >
> 6c12ff0021f80eea22666e4ae625b150SYSTEM.CATALOG,,1397780246020.6c12ff0021f80eea22666e4ae625b150.
> > > state=FAILED_OPEN, ts=Tue Jul 29 16:45:20 PDT 2014 (1469s ago),
> > > server=host_name,60020,1406677501761
> > >
> > > How can i fix or debug this problem?
> > >
> > > --
> > > Thanks & Regards,
> > > Anil Gupta
> > >
> >
>
>
>
> --
> Thanks & Regards,
> Anil Gupta
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message