hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From AnandaVelMurugan Chandra Mohan <ananthu2...@gmail.com>
Subject Re: HBase client code for 0.98.3
Date Tue, 01 Jul 2014 04:18:48 GMT
Hi,

I got it working. It was because of some of the old jars in class path.
Thanks for the help.

Regards,
Anand


On Mon, Jun 30, 2014 at 6:02 PM, Ted Yu <yuzhihong@gmail.com> wrote:

> Can you pastebin complete stack trace ?
>
> During upgrade, did you follow
> http://hbase.apache.org/book/upgrade0.96.html ?
>
> Have you rebuilt your client against 0.98 (I think you have, just
> confirming)?
>
> Cheers
>
> On Jun 30, 2014, at 5:13 AM, AnandaVelMurugan Chandra Mohan <
> ananthu2050@gmail.com> wrote:
>
> > Hi,
> >
> > Recently my Hbase cluster was migrated to 0.98.3 from 0.92 version. Now
> all
> > my java client code which scans the table and puts data into the table is
> > not working.
> >
> > Earlier I use to set just the hbase quorum in the Configuration object
> and
> > open the table using that configuration object. Now it hangs at that step
> > and I am getting the following exception after very long time
> >
> > org.apache.hadoop.hbase.client.NoServerForRegionException
> >
> > Any idea why I am getting this error? But I can scan the table in HBase
> > shell. Am I missing something. Please let me know. Thanks.
> >
> > --
> > Regards,
> > Anand
>



-- 
Regards,
Anand

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message