hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephen Boesch <java...@gmail.com>
Subject Maven repo missing jars for hbase package - but works fine for others such as hbase-common/client/etc)
Date Thu, 19 Jun 2014 23:14:25 GMT
The following hbase artifacts from maven work JUST FINE including the
sources:

hbase-client
hbase-common
hbase-server
hbase-shell
hbase-examples
hbase-thrift
hbase-protocol

Here is an example of the repo for hbase-common that contains all the
correct artifacts:

http://mvnrepository.com/artifact/org.apache.hbase/hbase-common/0.96.1.1-hadoop1


HOWEVER the

hbase    (base package)

does NOT work.

I tried two different versions:

0.9.6.1.1-hadoop1
0.98.3-hadoop1

I get the following errors:

[warn] [NOT FOUND  ] org.apache.hbase#hbase;0.98.3-hadoop1!hbase.jar (0ms)
[warn] ==== public: tried
[warn]
http://repo1.maven.org/maven2/org/apache/hbase/hbase/0.98.3-hadoop1/hbase-0.98.3-hadoop1.jar
[warn] [NOT FOUND  ] org.apache.hbase#hbase;0.98.3-hadoop1!hbase.jar(src)
(129ms)
[warn] ==== public: tried
[warn]
http://repo1.maven.org/maven2/org/apache/hbase/hbase/0.98.3-hadoop1/hbase-0.98.3-hadoop1-sources.jar
[warn] ::::::::::::::::::::::::::::::::::::::::::::::
[warn] ::              FAILED DOWNLOADS            ::
[warn] :: ^ see resolution messages for details  ^ ::
[warn] ::::::::::::::::::::::::::::::::::::::::::::::
[warn] :: org.apache.hbase#hbase;0.98.3-hadoop1!hbase.jar
[warn] :: org.apache.hbase#hbase;0.98.3-hadoop1!hbase.jar(src)
[warn] ::::::::::::::::::::::::::::::::::::::::::::::


Notice: there are NO jar files here:

http://central.maven.org/maven2/org/apache/hbase/hbase/0.96.1.1-hadoop1/

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message