hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From yogesh bedekar <yogesh.bede...@oracle.com>
Subject HBase connectivity issue
Date Tue, 20 May 2014 06:57:11 GMT
Hi,

I am using HBase 0.94.8 in my maven project.
I am trying to conect to an HBase database that is on the same node in 
this project.

I am getting the following following exception :-

14/05/14 02:45:17 INFO zookeeper.ZooKeeper: Initiating client
connection, connectString=blr2211457.idc.oracle.com:2182
sessionTimeout=180000 watcher=hconnection
14/05/14 02:45:17 INFO zookeeper.RecoverableZooKeeper: The identifier of
this process is 29532@blr2211457
14/05/14 02:45:17 WARN zookeeper.ClientCnxn: Session 0x0 for server
null, unexpected error, closing socket connection and attempting reconnect
java.lang.IllegalArgumentException: No Configuration was registered that
can handle the configuration named Client
at
com.bea.common.security.jdkutils.JAASConfiguration.getAppConfigurationEntry(JAASConfiguration.java:130)
at
org.apache.zookeeper.client.ZooKeeperSaslClient.<init>(ZooKeeperSaslClient.java:97)
at
org.apache.zookeeper.ClientCnxn$SendThread.startConnect(ClientCnxn.java:943)
at org.apache.zookeeper.ClientCnxn$SendThread.run(ClientCnxn.java:993)
14/05/14 02:45:18 WARN zookeeper.RecoverableZooKeeper: Possibly

I have not enabled security in the hbase-site.xml.
I am embedding an hbase-site.xml into my maven project.

It has the following entries :-

<configuration>
   <property>
     <name>hbase.defaults.for.version</name>
     <value>0.94.8-SNAPSHOT</value>
   </property>

   <property>
     <name>hbase.defaults.for.version.skip</name>
     <value>true</value>
   </property>
    <property>
     <name>hbase.zookeeper.quorum</name>
     <value>blr2211457.idc.oracle.com</value>
     <description>The directory shared by RegionServers.
     </description>
   </property>
    <property>
     <name>hbase.zookeeper.property.clientPort</name>
     <value>2181</value>
     <description>The directory shared by RegionServers.
     </description>
   </property>
    <property>
     <name>hbase.master</name>
     <value>blr2211457.idc.oracle.com:60000</value>
     <description>The directory shared by RegionServers.
     </description>
   </property>
   <property>
   <name>hbase.rootdir</name>
<value>hdfs://blr2211457.idc.oracle.com:8020/hbase</value>
</property>
</configuration>

I confirmed that this file is being read successfully and its properties 
are being used.

The hbase-site.xml in the database has the following entries -

<configuration>
   <property>
     <name>hbase.rootdir</name>
<value>file:///scratch/ybedekar/hbase0.94.8logs/hbase</value>
   </property>
   <property>
     <name>hbase.zookeeper.property.dataDir</name>
<value>/scratch/ybedekar/hbase0.94.8logs/zookeeper</value>
   </property>
    <property>
         <name>hbase.security.authorization</name>
         <value>false</value>
       </property>
</configuration>

Thanks in advance for any help in resolving this.

Thanks,
Yogesh

Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message