hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Marc Spaggiari <jean-m...@spaggiari.org>
Subject Re: HBase resolveDns error in log
Date Thu, 03 Apr 2014 19:00:15 GMT
I see that every 10 minutes on my scheduled MR jobs for the last months
without any issue. I think it should be a WARN and not an ERROR.

You can just ignore it.

JM


2014-04-03 4:53 GMT-04:00 Amit Sela <amits@infolinks.com>:

> Hi all,
>
> I'm running Hadoop 1.0.4 and HBase 0.94.12.
> I'm also running a Hadoop and HBase OSGi client where most modifications
> were in configuration Objects (Hadoop and HBase) where Class Loader is set
> to the bundle's CL instead of TCCL.
>
> I manage to successfully execute MapReduce jobs writing to HBase through
> API and with Bulk Load. I also have no problems in access to HBase (read,
> write...).
>
> The only problem I have is with MapReduce where HBase is source. I get the
> following error:
>
> *TableInputFormatBase   ยป Cannot resolve the host name for
> /xx.xx.xx.xx because of javax.naming.NameNotFoundException: DNS name not
> found [response code 3]; remaining name 'xx.xx.xx.xx.in-addr.arpa'*
>
> Inspite of the log error, the MR executes perfectly.
>
> I know the error means that my DNS server does not have the dns records for
> my nodes, and it's right, I never had them there, but until I made the CL
> changes I never encountered this error, moreover, it works with the
> error...
>
> Can anyone help me understand what's changed ? is it "OK" to keep running
> with this error ?
>
> Thanks,
> Amit.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message